Rover 45 L Series Backfiring and White Smoke - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 2 (permalink) Old 11-04-2017, 08:13 Thread Starter
Registered User
 
Join Date: Feb 2016
Location: longbrigde
Car: Rover 45
Posts: 7
Unhappy Rover 45 L Series Backfiring and White Smoke

hello need some help

I have a rover 45 2.0l L series engine had it for 3 years sold car to a mate and he said the car ran but it wouldnt go passed 70mph it will die come down and pick back up again some times cut out but drive-able untill the bolt on the cam snapped damaging the valves so took of the head to find all the exhaust valves was bent and caps was cracked so took the head off replaced the head all new gaskets, valves stem seals, etc started up white smoke everywhere so i thought injectors so replaced them started it up a bit of smoke but cleared after a few mins runs fine on tick over but when you put your foot down slowly the car will rev up but you get to the top end the car sounds like its backfiring and lots of white smoke.

so the injectors have bin done, i read on the internet some people said its a blocked cat so i have removed it started the car with it off and the same thing happens, changed the EGR valve and cooler still happens so i thought the turbo was a fault so i also changed the turbo and the still happens i am putting in all this money in don't no what to try next would of been cheaper to buy a new complete engine put the money i put into this one i want to to work.

is it possible to have the fuel pump and cam timing 180 out ? will it still run i done everything i can think this is the last i can think of is there something i am missing?

NEED HELP PLEASE dont no what to do next ?
freakstarfish is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 18-04-2017, 21:24
Registered User
 
Join Date: May 2004
Location: Under a car near scunthorpe
Car: Maestros, 200, 600, ZTT
Posts: 25,366
Send a message via MSN to E_T_V
I would unplug the MAF sensor first of all.

Then if no improvement then re-check the fuel pump belt timing as this is really easy to get wrong.
E_T_V is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
K Series 16v New Head Gasket But Blowing White Smoke. Marmite214si MG ZR / Rover 25, 200 & Streetwise 9 08-06-2009 11:05
Rover 25 exhaust - white smoke + water? ~HermaN~ MG ZR / Rover 25, 200 & Streetwise 8 31-07-2007 20:19
Rover 220sdi White Smoke And Misfire 220SDI Diesel Forum! 14 29-09-2006 20:26
Rover 45 white smoke and misfiring problem mellow MG ZS / Rover 45 & 400 2 11-11-2005 16:43
Rover 111 - White smoke - misfire! help! RobsonGTO Metro / Rover 100 19 03-07-2005 10:09

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome