General Pektron SCU/BCU - Page 5 - MG-Rover.org Forums
 1Likes
Reply
 
LinkBack Thread Tools Rating: Thread Rating: 140 votes, 5.00 average. Display Modes
post #81 of 297 (permalink) Old 19-01-2012, 13:52
Registered User
 
Join Date: Jan 2012
Car: diesel
Posts: 5
big_ieu is offline  
Sponsored Links
Advertisement
 
post #82 of 297 (permalink) Old 19-01-2012, 14:25
Registered User
 
Join Date: Jan 2012
Car: diesel
Posts: 5
Quote:
Originally Posted by big_ieu View Post
you wouldn't happen to know or the manufacture or part number by any chance mate rs say i need to get that for them to match it

http://uk.rs-online.com/web/c/?searchTerm=TPIC6C595

theres the link i am unsure as of which to purchase
big_ieu is offline  
post #83 of 297 (permalink) Old 19-01-2012, 18:11 Thread Starter
Mmmm....Rover..
 
technozen's Avatar
 
Join Date: Mar 2002
Location: Brighton.
Car: Mk2 ZS 160, 200vi(RIP) & Freelander XEDi
Posts: 10,377
Send a message via MSN to technozen
Farnell 1651926

or

RS 526870

or

RS 526909

Free Fob Programming and Diagnostics for forum Supporters... see here.

Pektron SCU/BCU Technical Information and Common Faults... see here.

Discounted Pektron SCU/BCU Relay Replacement for forum Supporters... see here.
technozen is offline  
post #84 of 297 (permalink) Old 21-01-2012, 13:50
Registered User
 
Join Date: Jan 2012
Car: MG ZR
Posts: 18
Techno.... I too have sent a PM
Kevobmmd is offline  
post #85 of 297 (permalink) Old 23-01-2012, 19:28
Registered User
 
Join Date: Jan 2012
Car: diesel
Posts: 5
Thanks mate your a star
big_ieu is offline  
post #86 of 297 (permalink) Old 24-01-2012, 20:13
Registered User
 
Join Date: Dec 2007
Location: Dog House.....again
Car: CityRover
Posts: 1,569
Can you supply the piezo buzzer. It's 15mm diameter and 10mm apart solder pin fixings or do you know of a supplier and part number?

The ones I am finding on CPC are 7mm apart solder pin fixings.


Thanks in advance.
harbottle is offline  
post #87 of 297 (permalink) Old 24-01-2012, 21:14 Thread Starter
Mmmm....Rover..
 
technozen's Avatar
 
Join Date: Mar 2002
Location: Brighton.
Car: Mk2 ZS 160, 200vi(RIP) & Freelander XEDi
Posts: 10,377
Send a message via MSN to technozen
Try this from RS....

http://uk.rs-online.com/web/p/buzzers-sounders/5358196/

Free Fob Programming and Diagnostics for forum Supporters... see here.

Pektron SCU/BCU Technical Information and Common Faults... see here.

Discounted Pektron SCU/BCU Relay Replacement for forum Supporters... see here.
technozen is offline  
post #88 of 297 (permalink) Old 20-02-2012, 20:28
Registered User
 
Join Date: Nov 2002
Location: Derby
Car: Triumph Toledo + Toyota Auris
Posts: 213
I have got a spare Pektron Relay if anybody is interested. It was kindly given to me by another member on here so I'm happy to pass it on. Please PM me if you are interested.

I could not remove the BCU from my Rover 25 so I bypassed the Fog Light circuit with an external relay and logic. So if somebody buys a red 2005 Rover 25 with a strange box hidden under the dash it was mine !

Andy.
andy_thomas is offline  
post #89 of 297 (permalink) Old 05-03-2012, 10:42
Registered User
 
Join Date: Jun 2011
Car: MG ZR
Posts: 20
How easy is it to solder? I have never soldered before but i have been told its the chip that is causing my horn to be stuck on and needs to be soldered?
Is it worth giving it a go or should i just get it bypassed to another circuit?
Lee92 is offline  
post #90 of 297 (permalink) Old 05-03-2012, 20:21 Thread Starter
Mmmm....Rover..
 
technozen's Avatar
 
Join Date: Mar 2002
Location: Brighton.
Car: Mk2 ZS 160, 200vi(RIP) & Freelander XEDi
Posts: 10,377
Send a message via MSN to technozen
The IC in question is a surface mount component and measures about 10mm x 5mm, if you have never soldered before I wouldn't recommend that you begin on something like this.

Free Fob Programming and Diagnostics for forum Supporters... see here.

Pektron SCU/BCU Technical Information and Common Faults... see here.

Discounted Pektron SCU/BCU Relay Replacement for forum Supporters... see here.
technozen is offline  
post #91 of 297 (permalink) Old 16-03-2012, 16:33
Registered User
 
Join Date: Jun 2009
Car: MG TF
Posts: 1
The drivers window on my 2005 TF will not drive up. I can hear the relay operating when the switch is operated up. Can you confirm the problem is with the relay before I go ahead and replace it.

Many thanks.
cleach is offline  
post #92 of 297 (permalink) Old 16-03-2012, 21:25 Thread Starter
Mmmm....Rover..
 
technozen's Avatar
 
Join Date: Mar 2002
Location: Brighton.
Car: Mk2 ZS 160, 200vi(RIP) & Freelander XEDi
Posts: 10,377
Send a message via MSN to technozen
The drivers window uses two relays (both are contained in one physical package) and they operate in a see-saw fashion to alter the direction of the motor.
The fact that you can hear a click cannot be used as a guarantee that the relay is working, it could be only one of the two operating.

Given their lousy reliability track record I would be very sure that the relay is the cause of the fault.

Free Fob Programming and Diagnostics for forum Supporters... see here.

Pektron SCU/BCU Technical Information and Common Faults... see here.

Discounted Pektron SCU/BCU Relay Replacement for forum Supporters... see here.
technozen is offline  
post #93 of 297 (permalink) Old 22-04-2012, 20:57
Registered User
 
Join Date: Apr 2012
Car: MG TF
Posts: 24
Pektron SCU

I recently acquired MGTF 115 Reg 04, I have a number of issues to be resolved.
I have read you thread on the Pektron SCU fitted to MG TF (and other Rovers) and found it very interesting.
I believe I have a problem with my MGTF 115 Reg 2004 SCU as I have no Intermittent Wiper and a central locking issue with the passengers door and boot.
I have had a look at the PCB and noticed that there are whitish powder coming from two of the relays (one being the Wiper Relay the other Fogs and Horn) and also from the IC your reference B and similar marks by connector 660. Can you advise me whether you under take to repair the SCU and or supply the replacement relays.
I think the SCU has been previously replaced as the label inside details ICT-905660 5/10/05, AA- 0064359, CE0682 433. The label on outside of details YWC001541 S07, SCU A-0662G03B, A0073, FB200722, K e11, 022146. I would very much appreciate you comment and advice. Regards Mike Booth (User name Grey Old Boy)
Grey Old Boy is offline  
post #94 of 297 (permalink) Old 22-04-2012, 21:13 Thread Starter
Mmmm....Rover..
 
technozen's Avatar
 
Join Date: Mar 2002
Location: Brighton.
Car: Mk2 ZS 160, 200vi(RIP) & Freelander XEDi
Posts: 10,377
Send a message via MSN to technozen
The label on the inside is simply the manufacturers details for the radio receiver circuit board.

I'll send you a PM with details about repairs and spare parts.

Free Fob Programming and Diagnostics for forum Supporters... see here.

Pektron SCU/BCU Technical Information and Common Faults... see here.

Discounted Pektron SCU/BCU Relay Replacement for forum Supporters... see here.
technozen is offline  
post #95 of 297 (permalink) Old 23-04-2012, 09:45
Banned
 
Join Date: Dec 2011
Location: Swansea UK
Car: Rover 25 x3 MGZR 160
Posts: 428
Arrow Niagra

Sounds more like water damage and the residue is from that. (this can also be a reaction to 'no clean' fluxes (do not like water based cleaners) or a result of alcohol based cleaners to clean up flux after repairs)

Could well have other problems on the board not just relays.

Last edited by Remobilise Ltd; 23-04-2012 at 09:53.
Remobilise Ltd is offline  
post #96 of 297 (permalink) Old 23-04-2012, 19:21 Thread Starter
Mmmm....Rover..
 
technozen's Avatar
 
Join Date: Mar 2002
Location: Brighton.
Car: Mk2 ZS 160, 200vi(RIP) & Freelander XEDi
Posts: 10,377
Send a message via MSN to technozen
Water damage isn't a known problem on the TF.
I would concur that it is remains of the board wash process.

3 IC's, two transistors and a voltage regulator seem to be the common items to fail and are very easy to replace with the right equipment.

Free Fob Programming and Diagnostics for forum Supporters... see here.

Pektron SCU/BCU Technical Information and Common Faults... see here.

Discounted Pektron SCU/BCU Relay Replacement for forum Supporters... see here.
technozen is offline  
post #97 of 297 (permalink) Old 27-04-2012, 16:49 Thread Starter
Mmmm....Rover..
 
technozen's Avatar
 
Join Date: Mar 2002
Location: Brighton.
Car: Mk2 ZS 160, 200vi(RIP) & Freelander XEDi
Posts: 10,377
Send a message via MSN to technozen
It was indeed water ingress but it would seem that the car has had a replacement SCU fitted so I reckon the ingress was in the original vehicle.

To the naked eye the PCB looked ok but on removing the relays there was visible
staining, this was also present under one of the surface mount driver IC's and a capacitor.

Relays, chip and capacitor replaced and the SCU can re-enter service!

Free Fob Programming and Diagnostics for forum Supporters... see here.

Pektron SCU/BCU Technical Information and Common Faults... see here.

Discounted Pektron SCU/BCU Relay Replacement for forum Supporters... see here.
technozen is offline  
post #98 of 297 (permalink) Old 14-05-2012, 21:08
Registered User
 
Join Date: May 2012
Car: MG TF
Posts: 1
Blog Entries: 1
Intermitent wiper problem

I have a MG TF 160 Spark. The problem I have is with the intermittent wiper function. I suspect its the relay on the SCU but would appreciate any guidance. The issue is only with intermittent wipe all other functions are OK (SCU and wipers). When selected I intermittent wipe it mostly (but not always) get a buzz sound when the relay comes in, the wipers work and occasionally I get the low coolant warning light flicker with the relay buzz. I thought it might be a bad earth, I have disconnected all of them cleaned with contact cleaner, chased the thread and remade with copper grease. I also did the same to the battery connections. This has improved the situation but not eliminated the fault. Do you think replacing the intermittent relay would cure this ?
Thanks for any info
TF Spark is offline  
post #99 of 297 (permalink) Old 18-05-2012, 18:26
Registered User
 
Join Date: May 2012
Car: CityRover
Posts: 3
need relays :)

im after 5 relays but as ive only just started up i carnt do anythink for example PM techdozen so if i could get Pm'd or get allowed to pm i would be greatful

Thanks
razza101 is offline  
post #100 of 297 (permalink) Old 18-05-2012, 22:47
Registered User
 
Join Date: Dec 2007
Location: Dog House.....again
Car: CityRover
Posts: 1,569
Here you go, email the seller on this finsished ebay listing. I think this is Technozen's finished listing....sorry if its not

http://www.ebay.co.uk/itm/ws/eBayISA...m=160720501633
harbottle is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
SCU/BCU problem Loader MG ZR / Rover 25, 200 & Streetwise 2 20-09-2012 14:11
Pektron Clock hoof-hearted MG ZS / Rover 45 & 400 12 30-03-2011 23:22
is it a bcu scu issue??? paulryan1234 MG ZS / Rover 45 & 400 17 24-03-2010 13:26
Lucas or Pektron MGKayaker MG ZR / Rover 25, 200 & Streetwise 38 22-02-2010 19:04
pektron remotes roger1984 MG ZR / Rover 25, 200 & Streetwise 0 03-11-2009 19:09

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome