MG ZT V6 VIS motor running with ignition off.. - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 5 (permalink) Old 05-11-2016, 12:09 Thread Starter
Supporter
 
Join Date: Aug 2009
Location: The Kingdom of Fife
Car: MG ZT 190+, MG TF 135, MG Midget
Posts: 100
Garages
V6 VIS motor running with ignition off..

Hello this is a new one to me. I have a 2002 MG ZT 190 that's pick a new quirk.

Engine off, keys out, got out of the car and heard whirring from under the bonnet. Unplugged the VIS balance motor nearest windscreen and that was the culprit.

What was it doing and how do I stop it?

Until I figure it out I'm unplugging it each time I leave the car, and plugging in again. Not ideal.

I'm on my 3rd ZT V6 so have had these buggers in and out countless times but like I said, this is a new development with them.

Reminds me of when my 620TI would keep running with the ignition off & keys out, but that was an alternator shaking itself to bits & full of shrapnel.

Any help appreciated, I especially don't want people seeing me under the bonnet constantly, it gives them schadenfreude.
haribo is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-11-2016, 13:21
Registered User
 
Join Date: Nov 2008
Location: Gävle, Sweden
Car: Rover 75
Posts: 229
As far as I'm aware, unlike the power vis motor, the balance motor itself has no internal stop, it relies on the balance flap for that function. Could be worth examining the flap within the upper manifold to see if the spindle's broken.

Otherwise, replace with one of “stocktake’s” renovated and improved motors. You’ll usually find him on the enthusiasts or “club” forum.

Regards
vitesse v8 is offline  
post #3 of 5 (permalink) Old 05-11-2016, 14:15 Thread Starter
Supporter
 
Join Date: Aug 2009
Location: The Kingdom of Fife
Car: MG ZT 190+, MG TF 135, MG Midget
Posts: 100
Garages
Aha, I'll have it out for a look. I've had this ZT less than a year and not had any VIS issues until now, they've been behaving as they should.

Previous ZTs I had them in and out constantly, cleaning & shaving the balance flap was something I did a few times.

I do have a spare pair of dud VIS that could come in useful now, but might be one for Mr. Stocktakes, who's services I've called on a few times over the years..

I'm still puzzled why even a failed balance VIS would be powering away with ignition off & keys out though..
haribo is offline  
 
post #4 of 5 (permalink) Old 05-11-2016, 16:59 Thread Starter
Supporter
 
Join Date: Aug 2009
Location: The Kingdom of Fife
Car: MG ZT 190+, MG TF 135, MG Midget
Posts: 100
Garages
Got the Balance VIS out and you were spot on Vitesse, the spindle on the flap had sheared off.

I did a quick temporary repair as I need to drive it tonight, by slotting a metal blade through to enable it to turn (and stop) again.

Unfortunately the same whirring sound from the VIS when I stopped, so I've unplugged again. Either my fix failed immediately, or the fact that it's still powering away indicates something else, I'm completely stumped..

Critically, can I drive it in the meantime with the Balance VIS unplugged?

I wouldn't want to cause a catastrophe, but need to drive it, preferably without the hassle of being under the bonnet every time.

(I think I've driven before with VIS motors accidentally unplugged when I was having issues with previous ZTs)
haribo is offline  
post #5 of 5 (permalink) Old 05-11-2016, 17:55
Registered User
 
Join Date: Nov 2008
Location: Gävle, Sweden
Car: Rover 75
Posts: 229
Nice to be right for a change, must mention it to the wife!

Going out on a limb here but yes I you can. Lots of people drive around with defective vis motors without even knowing about it and I can't see that having it plugged in or not will make any difference. Sadly the flaps aren't available as spares.

Regards
vitesse v8 is offline  
Reply

Bookmarks

Tags
190, mg zt, vis

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
VIS Motor - help! Sovoth MG ZS / Rover 45 & 400 6 21-04-2010 12:39
Which VIS Motor? jord79 MG ZT / Rover 75 (Sponsored by Rimmer Bros) 2 27-01-2010 12:15
Vis Motor On The Way Out?? hayley b MG ZS / Rover 45 & 400 1 15-01-2008 14:42
Vis Motor? Grey MG ZS / Rover 45 & 400 3 16-12-2006 08:53
VIS Motor Nor MG ZS / Rover 45 & 400 3 01-12-2006 19:20

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome