rover 75 v6 losing coolant - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 1 (permalink) Old 31-03-2017, 20:02 Thread Starter
Registered User
 
Join Date: Apr 2010
Location: herts
Car: Rover 75
Posts: 20
Unhappy rover 75 v6 losing coolant

Hi guys havnt been on for a while as no probs with the car ,i have a 52 plate v6 petrol 49k on the clock, have had the car for 7 yrs, anyway i,m losing coolant and cant find from where ! there are no leaks in the rad or the pipes but if you look between the the 2 piston blocks there appears to be a reservoir of water laying on the casing! are there any pipes near there that could be causing the problem? there is no contamination in the oil or water so i am hopefull the head gasket is ok !any ideas ? thanks in advance tony. ------ updating the car has overheated now ! but the rads cold ! does this mean the water pump is faulty? steam seems to be coming from the left side of the engine under the alternator .

Last edited by tonycee; 01-04-2017 at 21:16.
tonycee is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rover 45 Losing Coolant HELP :( r0ver MG ZS / Rover 45 & 400 8 20-04-2016 11:07
Rover 75 1.8T Losing coolant and burning oil Southside MG ZT / Rover 75 (Sponsored by Rimmer Bros) 3 07-01-2012 21:47
Losing coolant, losing oil. No milkshake, no mayo. chris1987 MG ZR / Rover 25, 200 & Streetwise 4 01-12-2011 19:07
Rover 400 1.4i losing coolant!!! Er!K MG ZS / Rover 45 & 400 2 07-10-2009 16:51
Rover 216 Losing coolant Rovey MG ZR / Rover 25, 200 & Streetwise 2 14-10-2008 17:05

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome