MG-Rover.org Forums - View Profile: bigbadbubba

bigbadbubba bigbadbubba is offline

Registered User

  Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. bigbadbubba
    25-01-2012 11:42 - permalink
    bigbadbubba
    Greetings people , i dont know if im going off my head but things seem to be going wrong and i cant find anything ! my brakes seem to be playing up but the garage cant find anything so i thought i would ask on here to see if anyone can help... there seems to me to be a bit of play in the pedal as in when i press it , it kind of sinks an inch sometimes . as i said iv had the car in a garage and they stripped the brakes down and cant find anything ?? all is good they say... fluid seems to be well up as well . also on the very odd occasion when i turn right, when i square up the wheels it tugs back to the right a wee bit , gives you a fear at times i can tell you . Can anyone enlighten me as to what it could be and proveto me that im not going off me head .... cheers in advance ,

    mike . ( BBB )

  About Me

  • About bigbadbubba
    Where did you hear of this site?
    Google Internet Search
    What make of car do you drive?
    MG ZT 114 cdti
    Any modifications to your car?
    chip fitted , now pullin 167bhp at 4500rpm !!!!
    s/s exhaust .
    Your Country
    Scotland
    Location
    ABERDEEN
    Biography
    43 , overweight , skinheed , bushy goaty beard , as hard as a ****e hoose rat ....;-)
    Interests
    Fair weather golfer , keeping my car clean . 3 daughters & 3 dogs - its nae easy bein me !!

  Statistics

Total Posts
Visitor Messages
Blog
General Information
  • Last Activity: 22-07-2015 21:13
  • Join Date: 01-10-2009
  • Referrals: 0

  Friends

Showing Friends 1 to 1 of 1
  • simcor
    • simcor is offline

  Mentions

No results to display...

  Quotes

No results to display...
 
For the best viewing experience please update your browser to Google Chrome