My new MG3 (new to me) - Page 2 - MG-Rover.org Forums
 2Likes
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
post #21 of 44 (permalink) Old 29-01-2017, 07:48
gnu
Supporter
 
gnu's Avatar
 
Join Date: Mar 2010
Location: Bristol
Car: MG ZS & Rover 200
Posts: 3,918
Blog Entries: 15
Garages
Quote:
Originally Posted by simcor View Post
Very sad to say car has picked up some damage already, gutted isn't the word. Rear bumper left hand side just above the reflector....
Bad luck mate. Strange how these things always seem to happen when you have a new car.

I got massive dents in the R214 on wing and door in a multistorey. Knocked out the best I could but still spoils the car. Too many massive SUVs around driven by people who shouldn't imo.

gnu
gnu is offline  
Sponsored Links
Advertisement
 
post #22 of 44 (permalink) Old 29-01-2017, 12:29 Thread Starter
Registered User
 
Join Date: Jun 2007
Location: Derbyshire
Car: 2013 MG 3 VTI Tech Style
Posts: 11,533
Quote:
Originally Posted by gnu View Post
Can you just change the sound system in the car to something better? Or is it integrated to the satnav and other stuff?
It would be possible to fit a standard stereo with an adapter plate but I want to keep it standard as the sound system is pretty bloody good in it and keep the OEM hands-free etc.
simcor is offline  
post #23 of 44 (permalink) Old 05-02-2017, 07:50
Registered User
 
Join Date: Sep 2002
Location: Bolton, Greater Manchester!
Car: MG ZS 120+ , MG ZR TD, MG TF 135 and MG3 Style.
Posts: 4,938
I think to solve the issue with the DAB you need to do a full reset on the head unit. I think we had an issue where it would only find Total FM.

Try another memory stick. I use WMA files rather than mp3 but had no issues other than the stereo being a bit fiddly.
michaelb is offline  
 
post #24 of 44 (permalink) Old 05-02-2017, 08:56 Thread Starter
Registered User
 
Join Date: Jun 2007
Location: Derbyshire
Car: 2013 MG 3 VTI Tech Style
Posts: 11,533
Quote:
Originally Posted by michaelb View Post
I think to solve the issue with the DAB you need to do a full reset on the head unit. I think we had an issue where it would only find Total FM.

Try another memory stick. I use WMA files rather than mp3 but had no issues other than the stereo being a bit fiddly.
Any idea on how to do a full reset?

I tried 3 different memory sticks and it won't even select USB it will select FM, Aux and Bluetooth but not USB the option does not show up.
simcor is offline  
post #25 of 44 (permalink) Old 05-02-2017, 09:11
Registered User
 
Join Date: Sep 2002
Location: Bolton, Greater Manchester!
Car: MG ZS 120+ , MG ZR TD, MG TF 135 and MG3 Style.
Posts: 4,938
Quote:
Originally Posted by simcor View Post
Any idea on how to do a full reset?

I tried 3 different memory sticks and it won't even select USB it will select FM, Aux and Bluetooth but not USB the option does not show up.
I think u just need to do a full re-scan for dab stations. Sorry its not really a reset but it is what we did.

I think it will only give you the USB option if it detects something. Does the port work? Try if it will charge something.
michaelb is offline  
post #26 of 44 (permalink) Old 05-02-2017, 09:13
Registered User
 
Join Date: Sep 2002
Location: Bolton, Greater Manchester!
Car: MG ZS 120+ , MG ZR TD, MG TF 135 and MG3 Style.
Posts: 4,938
Menu, DAB settings, Station List Refresh.

picked that up off another forum....hope it works.
michaelb is offline  
post #27 of 44 (permalink) Old 05-02-2017, 09:16 Thread Starter
Registered User
 
Join Date: Jun 2007
Location: Derbyshire
Car: 2013 MG 3 VTI Tech Style
Posts: 11,533
Quote:
Originally Posted by michaelb View Post
Menu, DAB settings, Station List Refresh.

picked that up off another forum....hope it works.
Already tried that that does not do anything either but thanks anyway, as I say i think it must be the DAB box that is faulty assuming that is also what it uses for the USB stick playback, it's the only conclusion I can come up with, other than if it is a problem with the actual head unit.

I have contacted a breaker with a 3 for the cost and location of the DAB box although I think it may be behind the lower console forward of the gear stick so will wait to see what they come back with, however I am going to try removing the fuse for a while for the Entertainment system and see if that does anything.
simcor is offline  
post #28 of 44 (permalink) Old 05-02-2017, 09:19 Thread Starter
Registered User
 
Join Date: Jun 2007
Location: Derbyshire
Car: 2013 MG 3 VTI Tech Style
Posts: 11,533
Still enjoying the car though especially round the lanes it really is pretty chuckable into the bends.

I averaged 36MPG the first week mainly a commute to work and back A and B roads with some duel carriageway, plus a 120 mile round trip on the motorway at a steady 70-75 mph on cruise.

I was hoping for slightly better with a longish motorway journey but that is still only 6mpg worse than my Diesel Focus was doing so not a massive amount less. The OBC computer was showing an average of 36.6mpg so seems to be very accurate only .6mpg out.
simcor is offline  
post #29 of 44 (permalink) Old 05-02-2017, 09:20 Thread Starter
Registered User
 
Join Date: Jun 2007
Location: Derbyshire
Car: 2013 MG 3 VTI Tech Style
Posts: 11,533
Quote:
Originally Posted by michaelb View Post
I think u just need to do a full re-scan for dab stations. Sorry its not really a reset but it is what we did.

I think it will only give you the USB option if it detects something. Does the port work? Try if it will charge something.
The USB port does indeed charge my phone.
simcor is offline  
post #30 of 44 (permalink) Old 05-02-2017, 09:20
Registered User
 
Join Date: Sep 2002
Location: Bolton, Greater Manchester!
Car: MG ZS 120+ , MG ZR TD, MG TF 135 and MG3 Style.
Posts: 4,938
Quote:
Originally Posted by simcor View Post
Already tried that that does not do anything either but thanks anyway, as I say i think it must be the DAB box that is faulty assuming that is also what it uses for the USB stick playback, it's the only conclusion I can come up with, other than if it is a problem with the actual head unit.

I have contacted a breaker with a 3 for the cost and location of the DAB box although I think it may be behind the lower console forward of the gear stick so will wait to see what they come back with, however I am going to try removing the fuse for a while for the Entertainment system and see if that does anything.
If you bought from a Dealer then I would take it back personally.
michaelb is offline  
post #31 of 44 (permalink) Old 05-02-2017, 09:23
Registered User
 
Join Date: Sep 2002
Location: Bolton, Greater Manchester!
Car: MG ZS 120+ , MG ZR TD, MG TF 135 and MG3 Style.
Posts: 4,938
Quote:
Originally Posted by simcor View Post
Still enjoying the car though especially round the lanes it really is pretty chuckable into the bends.

I averaged 36MPG the first week mainly a commute to work and back A and B roads with some duel carriageway, plus a 120 mile round trip on the motorway at a steady 70-75 mph on cruise.

I was hoping for slightly better with a longish motorway journey but that is still only 6mpg worse than my Diesel Focus was doing so not a massive amount less. The OBC computer was showing an average of 36.6mpg so seems to be very accurate only .6mpg out.
Fuel economy is the one gripe I have with the 3. I just feel it could be better.......but I did have a ZR Diesel before.
michaelb is offline  
post #32 of 44 (permalink) Old 05-02-2017, 09:41 Thread Starter
Registered User
 
Join Date: Jun 2007
Location: Derbyshire
Car: 2013 MG 3 VTI Tech Style
Posts: 11,533
Quote:
Originally Posted by michaelb View Post
If you bought from a Dealer then I would take it back personally.
Problem is the warranty they give is for engine and gearbox so won't cover something like the DAB not working, it is an ex MG dealer as well so they don't have that much interest in the MG's anymore. I fear he will be glad to see the back of the other 3 he has for sale.

I fear this is one with the faulty modules and has probably been like it since new and the previous owner never even bothered using either of those functions, because it is just over 3 years old it is out of it's MG warranty.
simcor is offline  
post #33 of 44 (permalink) Old 05-02-2017, 09:43 Thread Starter
Registered User
 
Join Date: Jun 2007
Location: Derbyshire
Car: 2013 MG 3 VTI Tech Style
Posts: 11,533
Quote:
Originally Posted by michaelb View Post
Fuel economy is the one gripe I have with the 3. I just feel it could be better.......but I did have a ZR Diesel before.
I am trying to drive it the same as the Corsa hire car I had, I managed 42mpg in that going to work and back, that was a 1.4 petrol with something like 70 or 80 bhp and really was hard going, so 36 out of a 1.5 with over 100 bhp isn't that bad I don't think.
simcor is offline  
post #34 of 44 (permalink) Old 05-02-2017, 09:45 Thread Starter
Registered User
 
Join Date: Jun 2007
Location: Derbyshire
Car: 2013 MG 3 VTI Tech Style
Posts: 11,533
I also think with the rumoured 1.5 turbo in the new compact SUV had that engine been in the 3 from the start fuel economy would be better and it would be a proper warm/hot hatch.

It is absolutely crying out for a turbo version imho.
simcor is offline  
post #35 of 44 (permalink) Old 05-02-2017, 09:58
Registered User
 
Join Date: Sep 2002
Location: Bolton, Greater Manchester!
Car: MG ZS 120+ , MG ZR TD, MG TF 135 and MG3 Style.
Posts: 4,938
Quote:
Originally Posted by simcor View Post
Problem is the warranty they give is for engine and gearbox so won't cover something like the DAB not working, it is an ex MG dealer as well so they don't have that much interest in the MG's anymore. I fear he will be glad to see the back of the other 3 he has for sale.

I fear this is one with the faulty modules and has probably been like it since new and the previous owner never even bothered using either of those functions, because it is just over 3 years old it is out of it's MG warranty.
It still has to be fit for purpose which clearly it isn't.....I would still go back and see if you can get them to fix/replace. He could always replace with one out of the other 3 if you make enough fuss.

It may well be one of those with faulty modules.......if so then it clearly is a 'known' fault so if you get no joy with the dealer then try MG themselves.
michaelb is offline  
post #36 of 44 (permalink) Old 05-02-2017, 11:37 Thread Starter
Registered User
 
Join Date: Jun 2007
Location: Derbyshire
Car: 2013 MG 3 VTI Tech Style
Posts: 11,533
Quote:
Originally Posted by michaelb View Post
It still has to be fit for purpose which clearly it isn't.....I would still go back and see if you can get them to fix/replace. He could always replace with one out of the other 3 if you make enough fuss.

It may well be one of those with faulty modules.......if so then it clearly is a 'known' fault so if you get no joy with the dealer then try MG themselves.
Yeah I will probably try that, not sure a faulty radio module comes into play really with "fit for purpose" as the FM/CD and bluetooth all work, had it been the whole radio then I think it's more likely to be replaced under the "fit for purpose" scenario.

I think I need to get them to look at it anyway, sometimes I get a bit of judder in first gear when pulling off, at first I thought it was just me getting used to driving a petrol again but it seems to do it regardless of how much revs you give it, I have also noticed a little rattle in reverse a couple of times which worries me slightly but again it doesn't happen all the time. I also think it's pretty whiny in reverse but then again most cars are, maybe i'm looking for faults that are not there though due to reading forums with potential issues.
simcor is offline  
post #37 of 44 (permalink) Old 08-02-2017, 18:49 Thread Starter
Registered User
 
Join Date: Jun 2007
Location: Derbyshire
Car: 2013 MG 3 VTI Tech Style
Posts: 11,533
MPG for the second week computer showing 38.8 actual 36. So this week 2.8 mpg out when last week it was only .6 mpg out. Very odd.
But looks like 36 to be the norm. This week has all been local running around with trips to work and back of around 10 miles. The week before was work and running around and 60 mile each way motorway journey. I'd like to drive it like I stole it for a week to see how low I can get it but I'd end up getting done for speeding lol
simcor is offline  
post #38 of 44 (permalink) Old 09-02-2017, 19:16 Thread Starter
Registered User
 
Join Date: Jun 2007
Location: Derbyshire
Car: 2013 MG 3 VTI Tech Style
Posts: 11,533
All in all I still can't really fault the car apart from the little niggles I have with it. The problem is with the handling I want to just chuck it around at times lol it does encore you to drive it lively rather than sedately. I was hoping for nearer to 40mpg as I thought that would be achievable. Maybe if I was doing longer journeys and at 60mph then I could probably get 40+ but I hate people who dawdle on motorways. Lol
simcor is offline  
post #39 of 44 (permalink) Old 10-02-2017, 16:50
Registered User
 
Join Date: May 2004
Car: Rover 211 MG ZS 120 MG ZT 160T ZTT 120 MG3 Style MG ZS 180
Posts: 3,151
Early 40's should be achievable on a commute, nearly 50 on a motorway drive. I do like the 3 in red.
mattie007 is offline  
post #40 of 44 (permalink) Old 10-02-2017, 16:54
Registered User
 
Join Date: Sep 2016
Car: MG 6 GT
Posts: 44
It's a car that looks great in almost every colour. The grey is particularly striking, much better in the metal than in pictures. Racing green would be a nice addition, but unlikely as the Chinese consider it unlucky.
LondonMG is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Google Translate... on MG3 'Fashion modeling MG3 achievement British fashion charm' Ann MG Writer MG / SAIC / Roewe Related Chat 7 10-08-2014 22:38
My new MG3 MGR_Petrolhead MG 3 21 09-07-2014 14:26
MG3 Ad? JohnMandersand MG 3 40 19-09-2013 18:30
mg3 on m5 littlechicken MG 3 0 29-08-2013 09:10

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome