Glowplug relay bypass - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 6 (permalink) Old 30-04-2017, 17:17 Thread Starter
Registered User
 
Join Date: Jan 2017
Posts: 12
Glowplug relay bypass

Having issues with the glowplug relay. Bought one to replace a failed one and now that's gone too. Anybody know what faults may cause that? Also wondered if anyone has made a bypass with a switch and how they did it? Any ideas would be appreciated!
Bathrat is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-05-2017, 21:15
Registered User
 
Join Date: May 2004
Location: Under a car near scunthorpe
Car: Maestros, 200, 600, ZTT
Posts: 25,348
Send a message via MSN to E_T_V
How has the replacement failed?

It is worth noting that the light on the dash has no relation to when the glow plugs are turned on.
E_T_V is offline  
post #3 of 6 (permalink) Old 03-05-2017, 12:54 Thread Starter
Registered User
 
Join Date: Jan 2017
Posts: 12
It stopped working. I'm aware the light comes on anyway, as i say it's a problem that's happened before so just wondered if it's a common issue and if so has anyone set up a bypass and what did they use to do so.
Bathrat is offline  
 
post #4 of 6 (permalink) Old 04-05-2017, 22:44
Registered User
 
Join Date: May 2004
Location: Under a car near scunthorpe
Car: Maestros, 200, 600, ZTT
Posts: 25,348
Send a message via MSN to E_T_V
Relays do occasionally fail, but a bypass isn't going to help that as it is the power contacts that burn out.

The light on the dash still comes on even when the glow plugs are not used/needed.

I assume you are testing for voltage at the plugs when someone turns the ignition key on with a cold engine?
E_T_V is offline  
post #5 of 6 (permalink) Old 05-05-2017, 09:18 Thread Starter
Registered User
 
Join Date: Jan 2017
Posts: 12
No voltage is reaching the plugs. My garage told me to try a bypass straight to the plugs as that's what they did when they found the relay wasn't working and it fired up right away. I bought a new relay and it was all quick start until this relay went and I'm back to long cranking. I can only think something is blowing the relays out.
Bathrat is offline  
post #6 of 6 (permalink) Old 05-05-2017, 20:50
Registered User
 
Join Date: May 2004
Location: Under a car near scunthorpe
Car: Maestros, 200, 600, ZTT
Posts: 25,348
Send a message via MSN to E_T_V
Measure the resistance of the plugs (after removing the electical connector from the top). Resistance should be an ohm or 2. If zero then it is a dead short and that may be the reason you are overloading the relay. If inifinite that plug isn't working either. Replace any dead ones and see if that helps. I assume you've fitted the proper relay with the huge electrical contacts (rather than a normal auto relay).
E_T_V is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
mg zr glowplug relay/timer richtryinghard MG ZR / Rover 25, 200 & Streetwise 5 01-02-2013 20:45
MZ TR - Glowplug relay sbk1972 Diesel Forum! 4 03-04-2012 20:13
Glowplug relay under bonnet JonnyB1978 Diesel Forum! 8 18-09-2009 22:04
R75 CDT Glowplug Relay oh look its me Wanted 0 09-03-2008 11:23
Rover 115SD glowplug relay 'chatter' shigg Metro / Rover 100 14 11-01-2003 07:17

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome