HELP Losing the will to live ! - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 3 (permalink) Old 08-02-2017, 17:54 Thread Starter
Registered User
 
Join Date: Feb 2017
Car: CityRover
Posts: 1
HELP Losing the will to live !

SO over a month ago now My car Mg rover zr 55 plate NX55FVO keeps revving when i use the accelerator it comes up and down 2 to 3 then 3 to 4 ect. I have had so many different parts wires ect. Changed the idle air controlle vale and Throttle position sensor. Now ive been told its 10000% Mass air flow sensor. Looking online and asking Garages ive can only see a mass air flow for
2.0 Diseal cars, also been told there is such no thing on my make of car and said "The K series engine never had a Mass Air Flow Sensor fitted, it only ever had a MAP sensor which is part number 16873/LMS065. "

Has anyone got any ideas whats going on and is there a Mass air flow sensor on my car or not as the recovery man was messing with it and he told me he has an mg and its 100% that part as said above

Thanks
Jamie Hackett is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-02-2017, 18:02
Rover Lifestyle
 
Roverlike's Avatar
 
Join Date: Aug 2009
Location: Split, Croatia
Car: Rover 200 (95-99) 'Bubble Shape' & Rover 600
Posts: 10,688
Moved to proper section on the forum... you should get better attention here.
Roverlike is offline  
post #3 of 3 (permalink) Old 09-02-2017, 06:27
Registered User
 
Join Date: May 2004
Location: Under a car near scunthorpe
Car: Maestros, 200, 600, ZTT
Posts: 25,366
Send a message via MSN to E_T_V
Quote:
Originally Posted by Jamie Hackett View Post
SO over a month ago now My car Mg rover zr 55 plate NX55FVO keeps revving when i use the accelerator it comes up and down 2 to 3 then 3 to 4 ect. I have had so many different parts wires ect. Changed the idle air controlle vale and Throttle position sensor. Now ive been told its 10000% Mass air flow sensor. Looking online and asking Garages ive can only see a mass air flow for
2.0 Diseal cars, also been told there is such no thing on my make of car and said "The K series engine never had a Mass Air Flow Sensor fitted, it only ever had a MAP sensor which is part number 16873/LMS065. "

Has anyone got any ideas whats going on and is there a Mass air flow sensor on my car or not as the recovery man was messing with it and he told me he has an mg and its 100% that part as said above

Thanks
What engine do you have?

No 200/25/zr petrol had a maf sensor fitted
Diesel 200/25/zr's did (but the maf on the 200 can be safely unplugged/ignored as it doesn't majorly affect the fuelling.


What are the symptoms?
If the throttle is actually sticking open and you have a plastic throttle body that isn't unknown and a new/second hand throttle body can cure it
If it is a leaking inlet manifold gasket - again not unknown (but more usually known for leaking coolant) and will cause similar problems
I assume you've tried a throttle reset?

-turn igntion on - do not start the engine
- fully press and release the throttle pedal 5 times within 5 seconds
- you may hear a chattering noise from the engine - wait till it stops
- start engine and allow idle to stabilise
- complete
E_T_V is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Indicators. Losing will to live. Any ideas 884andy MG ZS / Rover 45 & 400 3 25-01-2016 20:26
Losing coolant, losing oil. No milkshake, no mayo. chris1987 MG ZR / Rover 25, 200 & Streetwise 4 01-12-2011 19:07
Do like my Rover but losing the will to live with this 'whooshing' noise..... Misssantosha MG ZR / Rover 25, 200 & Streetwise 7 01-05-2010 05:20
Coolant system wont bleed - losing the will to live!! dean84 Metro / Rover 100 2 06-11-2008 18:08
416i.... losing the will to live now billyboggins MG ZS / Rover 45 & 400 15 21-06-2007 23:54

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome