Problem with locating problem, probably lambda / oxygen senseor - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 1 (permalink) Old 09-04-2017, 09:44 Thread Starter
Registered User
 
Join Date: Apr 2017
Location: Gdynia
Car: Rover 214 Si 94'
Posts: 1
Problem with locating problem, probably lambda / oxygen senseor

Hello,
I have a Rover 214 Si 94' (103 bhp), and a problem shown on this video:

The rpms oscillate when in neutral, and after some time the engine often stops. Also, when I'm driving and i put in neutral and the rpms fall from eg. 2000 rpm, they sometimes fall so low that the engine stalls. Sometimes it just does 2000 - 500 - 900. I heard that this can be a problem with the lambda / oxygen sensor, could that be true? I already changed the spark plugs, distribution cap, ignition cables and the collector washer. I also hear it can be the throttle.

Also bonus question: is the 1.4 16v 103 bhp in the 89'-95' the same engine as the 1.4 16v 103 bhp in the 95'-99'? In Poland it's very easy to find parts for the 95'-99' Rover, and a lot harder to get the same parts for the older one.
Gajewa is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rover 25 Lambda/oxygen sensor miff Wanted 5 20-02-2010 13:47
Oxygen sensor problem ? rover turbo Rover 600 3 30-07-2009 16:50
Where are the Oxygen / Lambda Sensors? 6raeme MG ZT / Rover 75 (Sponsored by Rimmer Bros) 1 06-05-2009 12:15
Oxygen (lambda) sensor JeTBoy 'R8' Rovers (aka Wedges!!) 1 13-01-2009 21:32
216 Lambda/Oxygen Sensor NickCrax Others 0 23-07-2004 13:12

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome