car horn not working - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 2 (permalink) Old 02-07-2014, 18:38 Thread Starter
Registered User
 
Join Date: Apr 2010
Location: kilmarnock
Car: MG ZS
Posts: 50
Thumbs up car horn not working

just a cpl of lines to say my 05 plate zs horn stopped working just clicked when pushing button read on here common fault and replace horn etc took to my trusted garage and problem was at instrument cluster on steering wheel beeing worn 10 min fix and done just hope this helps if anyone having similer problems!!
munchybox is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 21-04-2017, 10:57
Registered User
 
Join Date: Apr 2017
Car: CityRover
Posts: 1
Sickspeed

I have the same problem with my 73 std. I have checked the contacts and the wiring but can't find the grounding source. It must be the ring as mentioned. I do not want to take my steeing column apart to fix my horn if I don't have to.
Lexy Thompson is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
54 plate mg zs horn not working power at switch but not at horn georgesrovers MG ZS / Rover 45 & 400 4 24-01-2015 13:35
Never had a car with a working horn Tenna MG ZR / Rover 25, 200 & Streetwise 13 23-04-2012 17:37
Horn not working Staffsdriver MGF and MGTF (Sponsored by MGFnTFBITZ) 14 06-04-2011 20:05
horn not working chris_h MG ZT / Rover 75 (Sponsored by Rimmer Bros) 3 05-02-2011 13:29
Left Horn button not working...will keys and car work ok after battery reconected? Dr Ben MGF and MGTF (Sponsored by MGFnTFBITZ) 6 13-11-2008 19:31

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome