Cooling fan doesn't stop - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 9 (permalink) Old 02-03-2012, 19:47 Thread Starter
Registered User
 
Join Date: Nov 2009
Car: MG ZS
Posts: 143
Cooling fan doesn't stop

Hi gents,

Since the last very cooled period in France I have a problem with my cooling fans.

Symptom:
- when I switch on ignition (when instrumental panel in on) and when air conditioning ventilation is at least set to speed 1, then cooling fans are running at low speed. When I switch off the ignition then the cooling fans stop
- when I switch on ignition (when instrumental panel in on) and when air conditioning ventilation is off, then cooling fans are not running at all


I am a bit lost, I don't understand how the air conditioning ventilation can affect the cooling fans.

Any idea how to troubleshoot?

Thanks

Stéphane
steph30 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 03-03-2012, 06:24
Registered User
 
Join Date: Jul 2008
Location: Bruges
Car: Rover 45
Posts: 1,160
Talking

Quote:
Originally Posted by steph30 View Post
Hi gents,

Since the last very cooled period in France I have a problem with my cooling fans.

Symptom:
- when I switch on ignition (when instrumental panel in on) and when air conditioning ventilation is at least set to speed 1, then cooling fans are running at low speed. When I switch off the ignition then the cooling fans stop
- when I switch on ignition (when instrumental panel in on) and when air conditioning ventilation is off, then cooling fans are not running at all


I am a bit lost, I don't understand how the air conditioning ventilation can affect the cooling fans.

Any idea how to troubleshoot?

Thanks

Stéphane
They always run with the aircon on
MARCOVH is offline  
post #3 of 9 (permalink) Old 04-03-2012, 18:44 Thread Starter
Registered User
 
Join Date: Nov 2009
Car: MG ZS
Posts: 143
Maybe.
But in my case aircon is off.
Only ventilation is on (manual mode).

Do I have a problem with my car?

Cheers
steph30 is offline  
post #4 of 9 (permalink) Old 04-03-2012, 18:56
Registered User
 
Join Date: Apr 2004
Car: MGZS180,MGZR160,MGF VVC,MG Maestro T16, Rover 111
Posts: 5,243
The secondary cooling fan will run if the aircon is on and the car is stationary or at low speed.

The main cooling fan will run if the ECU is getting an incorrect signal or no signal from the coolant tempreture sensor, there are 2, 1 just reads tempreture and the other is for switching the fan but I am not sure which is which.

Anyway, the fan will run if there is a problem with the sensor.

Can you get the computer read with T4 or OBD2?
Talkingcars is offline  
post #5 of 9 (permalink) Old 05-03-2012, 07:21
Registered User
 
Join Date: Jul 2008
Location: Bruges
Car: Rover 45
Posts: 1,160
Talking

Quote:
Originally Posted by Talkingcars View Post
The secondary cooling fan will run if the aircon is on and the car is stationary or at low speed.

The main cooling fan will run if the ECU is getting an incorrect signal or no signal from the coolant tempreture sensor, there are 2, 1 just reads tempreture and the other is for switching the fan but I am not sure which is which.

Anyway, the fan will run if there is a problem with the sensor.

Can you get the computer read with T4 or OBD2?
The one with the two wires goes to the ECU this one
http://www.rimmerbros.co.uk/Item--i-GRID003183
nr 13,the one with one wire goes to the temp gauge.They're in front off the engine bay on the coolant elbow coming out off the engine, where the coolant pipe is mounted on
MARCOVH is offline  
post #6 of 9 (permalink) Old 05-03-2012, 21:17 Thread Starter
Registered User
 
Join Date: Nov 2009
Car: MG ZS
Posts: 143
Ok then

I will start my work on this sensor and I will let you know.

Thanks
steph30 is offline  
post #7 of 9 (permalink) Old 06-03-2012, 04:34
Registered User
 
Join Date: Jul 2008
Location: Bruges
Car: Rover 45
Posts: 1,160
Talking

Quote:
Originally Posted by steph30 View Post
Ok then

I will start my work on this sensor and I will let you know.

Thanks
When you're quick you can change the temp-sensor without spilling any coolant (Cold engine offcourse)
MARCOVH is offline  
post #8 of 9 (permalink) Old 13-03-2012, 17:01 Thread Starter
Registered User
 
Join Date: Nov 2009
Car: MG ZS
Posts: 143
I just receive the new spare sensor I will try it.
But after a check, I saw that air con is running everytime even if selected off (manual mode on mk2).
Maybe the compressor clutch remains engaged whatever is the air con mode.

How can I check it?
steph30 is offline  
post #9 of 9 (permalink) Old 17-03-2012, 13:41 Thread Starter
Registered User
 
Join Date: Nov 2009
Car: MG ZS
Posts: 143
With the new sensor the fault remains.
With my diag tool, I read P0118 Engine Coolant Temperature Circuit High Input.

Do you know where does the problem come from?

Thanks for your help

Last edited by steph30; 17-03-2012 at 13:41. Reason: typo
steph30 is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cooling fan and a/c fan 2nd scale from scratch..? nikolas MG ZR / Rover 25, 200 & Streetwise 6 22-05-2011 22:49
Cooling fan or mind of its own fan geoff1 MG ZT / Rover 75 (Sponsored by Rimmer Bros) 24 19-02-2011 22:17
Fan wont stop on CDTi FerryScoob MG ZT / Rover 75 (Sponsored by Rimmer Bros) 7 24-01-2009 09:48
Rover 75 Cooling fan doesn't stop tomsu MG ZT / Rover 75 (Sponsored by Rimmer Bros) 4 21-09-2007 03:31
HELP... my fan won't stop... katiesue MG ZT / Rover 75 (Sponsored by Rimmer Bros) 7 21-07-2006 11:44

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome