MG ZS Enging struggling to put down power - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 2 (permalink) Old 18-03-2017, 18:41 Thread Starter
Registered User
 
Join Date: Feb 2017
Car: MG ZS
Posts: 1
Exclamation MG ZS Enging struggling to put down power

Hi, all, never been on this forum before and I'm not really that car savvy. got a 2005 1.6 MG ZS that is having some engine problems. Driving out and about today in the lower gears it feels like the car is struggling to put any power down on the ground, it will move for a maybe 10 seconds or so and it's like it finds what it's looking for and will move off at the speed its supposed to. This happens in 1st through 3rd ( have had it up to higher gears with this problem thus far ) When the car is idling it feels as if it's searching for the correct rhythm it normally runs at causing the whole car to shudder violently and can sometimes cause the engine to die all together, leaving it for 10 minutes or so and it will turn back over again but not before this time. No dash warning lights come on when this happens and the car has fuel, coolant and oil so anything else is beyond my knowledge.

Anything you guys can to do help would be great!

Cheers in advance
- Si
taits2204 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 18-03-2017, 20:17
gnu
Supporter
 
gnu's Avatar
 
Join Date: Mar 2010
Location: Bristol
Car: MG ZS & Rover 200
Posts: 4,042
Blog Entries: 15
Garages
Assuming it's been serviced and filters, plugs, oil etc have been changed to schedule, best to get the fault codes checked with a obd2 reader, as it could be many things. If oil and coolant are always stable, the HT circuit would be at the top of my list of possibilities...

gnu
gnu is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
enging inspection cover bolts gordongilchrist MGF and MGTF (Sponsored by MGFnTFBITZ) 17 20-08-2014 14:53
18G 1746A - Enging locking pin. eats-1964 MG ZT / Rover 75 (Sponsored by Rimmer Bros) 4 07-03-2010 19:05
Loss of power/enging "missing" on roundabout DHillary Diesel Forum! 6 23-01-2009 13:04
wheres the hole to put power cable on rover 75? jamiek In-Car Audio, Entertainment, Sat Nav etc... 1 16-07-2008 13:49
Power problems (Help before i put a match to it!!!!) DarrenB MGF and MGTF (Sponsored by MGFnTFBITZ) 11 10-01-2005 17:23

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome