Rover 45 - A/C Starts and stops - MG-Rover.org Forums
 1Likes
  • 1 Post By JohnRov
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 6 (permalink) Old 26-04-2017, 17:55 Thread Starter
Registered User
 
Join Date: Apr 2017
Location: Greece
Car: Rover 45
Posts: 10
Rover 45 - A/C Starts and stops

Hello everyone,

After engine replacement the "mechanic" didn't change the two o-rings in result of the system to loose the liquid.

After i replaced the leak with two new o-rings
recharged the system with the Correct method (Pressed the system up to 100psi waited - purge triple purge etc)

But i have this problem:

The compressor working for 20 seconds blowing cold air and then it stops for 1-5seconds and starts again i can feel it in the gas also powerloss - powerUPagain.

For me it seems like bad sensor (PROBE) or maybe the mechanic forgot to install something? any thermistor? I don't know much about car a/c.

I hope he didn't drain any oil from the compressor but i don't think so.

Thanks in advanced.
JohnRov is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-05-2017, 17:27
Rover Lifestyle
 
Roverlike's Avatar
 
Join Date: Aug 2009
Location: Split, Croatia
Car: Rover 200 (95-99) 'Bubble Shape' & Rover 600
Posts: 10,630
If you have power loss this might be connected with problems within AC cokpressor. Maybe worth to check if compressor pully if rotating freely?
Roverlike is offline  
post #3 of 6 (permalink) Old 01-05-2017, 17:51
Registered User
 
Join Date: May 2008
Location: Scunthorpe
Car: Rover 400 (95-99)
Posts: 1,534
the compressor does not run all the time , it will pressure the system up and make cold air , when everything is correct the compressor will stop till the pressure drops ( temp rises in system ) and then kick in again .
i would also check the receiver dryier has it ever been changed ? it might need renewing.
Andy400 is offline  
 
post #4 of 6 (permalink) Old 01-05-2017, 18:24
Registered User
 
Join Date: Apr 2004
Car: MGZS180,MGZR160,MGF VVC,MG Maestro T16, Rover 111
Posts: 5,734
Which type of air conditioning do you have?
Is it three control dials and two switches or is it a digital control panel?
Talkingcars is offline  
post #5 of 6 (permalink) Old 01-05-2017, 19:46 Thread Starter
Registered User
 
Join Date: Apr 2017
Location: Greece
Car: Rover 45
Posts: 10
Thanks for your answer,
@Roverlike I dont see any power loss battery and yes i hear a noise from the compressor pully.

@Andy400 No i don't have change the receiver dryier why do you think this may cause the issue?

@Talkingcars It is the Digital control


Thats why i did the question guys i don't know how it worked before but i think something is wrong

When i set the sepoint on 16 logically the compressor should work a lot not stopping every few seconds and then start again (i feel the gas going up and down and its bad)

Also when i set the setpoint on 30 the A/C acts like it is on 16 nothing different its just starts blowing cold air and then stops and start again.

*Yes i have cold air in the car when i used but i am afraid of this START/STOP i don't think is good for the compressor.

Last edited by Roverlike; 02-05-2017 at 05:04.
JohnRov is offline  
post #6 of 6 (permalink) Old 02-05-2017, 18:13 Thread Starter
Registered User
 
Join Date: Apr 2017
Location: Greece
Car: Rover 45
Posts: 10
Eventually the "problem" is fixed.

The issue was that Recycle air was ON in result of the a/c blowing 2 ℃ and the Probe took mistaken temperature from the vents in result of the start/stop of the compressor every 20 seconds.

After Recycle disabled the compressor working without stopping and with good hi/low pressure.(blowing 6-7 ℃)

Thanks again for all the help.
Talkingcars likes this.
JohnRov is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rover 25 starts then stops nexus490 MG ZR / Rover 25, 200 & Streetwise 4 20-06-2013 09:49
Rover 114 GSI fuel pump stops working when the engine starts to get hot paul from dud Metro / Rover 100 1 18-04-2013 11:17
Rover 220 td starts thens stops. trotter83 Diesel Forum! 23 01-09-2012 15:40
Starts Then Stops! alan589 MGF and MGTF (Sponsored by MGFnTFBITZ) 22 03-01-2008 13:53
Rover 400 starts then stops immediately joeboy1 MG ZS / Rover 45 & 400 2 12-07-2007 07:41

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome