Windscreen Washer and Driver's Side Passenger Window Not Working - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 5 (permalink) Old 16-03-2017, 14:07 Thread Starter
Registered User
 
Join Date: Apr 2006
Car: Rover 200 (95-99) 'Bubble Shape'
Posts: 45
Windscreen Washer and Driver's Side Passenger Window Not Working

Hi,

My Windscreen washer/jets and drivers side rear window have stopped working. I thought it might be the fuse so replaced it as I noticed there is one that is used by both the window and jets, however, it hasn't fixed anything. There is also a 20 amp fuse that is used by both jets that I changed but it didn't fix anything. Also on the fuses I pulled out I couldn't see that the fuse was blown (but don't know for sure you could see it has blown).

I'm guessing there's an electrical fault, where would I start to look?

Thanks
Ben
bendort is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 16-03-2017, 17:00
Rover Lifestyle
 
Roverlike's Avatar
 
Join Date: Aug 2009
Location: Split, Croatia
Car: Rover 200 (95-99) 'Bubble Shape'
Posts: 10,565
First of all what car and model year we are talking about here? This section and car model in your profile are pretty different.
Roverlike is offline  
post #3 of 5 (permalink) Old 17-03-2017, 10:05 Thread Starter
Registered User
 
Join Date: Apr 2006
Car: Rover 200 (95-99) 'Bubble Shape'
Posts: 45
Sorry, it's currently a Rover 45, diesel model (1.9l) from 2005.
bendort is offline  
 
post #4 of 5 (permalink) Old 17-03-2017, 17:06
Rover Lifestyle
 
Roverlike's Avatar
 
Join Date: Aug 2009
Location: Split, Croatia
Car: Rover 200 (95-99) 'Bubble Shape'
Posts: 10,565
I looked at the diagrams and I cannot find any point where these two problems are connected. They even do not share same fuse or earth point.

I would take multimeter and treat these two things as saparate problems. I would start measuring power on the window switches and driver motor. Also on the pump for jets.
Roverlike is offline  
post #5 of 5 (permalink) Old 20-03-2017, 10:00
Registered User
 
Join Date: Sep 2002
Location: Bolton, Greater Manchester!
Car: MG ZS 120+ , MG ZR TD, MG TF 135 and MG3 Style.
Posts: 4,939
Windscreen washers will be a failed relay in the BCU. I lost intermittent wipe when mine failed along with something else which I cannot remember.

Rear door window I don't think is driven by the bcu so this could be an issue with the motor itself.
michaelb is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Driver side heating warm, passenger side cold! hh1 MG ZT / Rover 75 (Sponsored by Rimmer Bros) 4 20-01-2013 11:17
driver side window not working rover_all_over Rover 600 8 30-03-2011 13:21
Driver Side front Electric window not working what should I look 4? Rover 25 (51 Reg) Mintygreen MG ZR / Rover 25, 200 & Streetwise 10 16-07-2008 22:24
rear windscreen washer not working shocka144 MG ZR / Rover 25, 200 & Streetwise 8 26-04-2007 15:26

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome