ZS 180 newbie with a couple of issues - MG-Rover.org Forums
 1Likes
  • 1 Post By Bren10
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 2 (permalink) Old 04-01-2017, 20:01 Thread Starter
Registered User
 
Join Date: Oct 2015
Car: MG ZR
Posts: 1
ZS 180 newbie with a couple of issues

Hi, newbie to the site as just purchased a Zs 180, couple of questions if I may,, oil change, what recommended oil should I use, also is there a guide on here as I don't wanna mess it up,,plus I aint looked under it yet, also radio in car, the live doesn't work, speakers are fine as tested, as new to the Zs, ive changed the fuse under steering wheel which had blown, cig lighter works now but the interior clock just lights up but doesn't display, plus still no live to radio, not the best at electrics so just wondering if there is a fuse in the engine bay fusebox,,any help appreciated, my 180 is a 2003 plate so guessing its a mark 1
cheers gang
Paul
wappa5384 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-01-2017, 00:27
Supporter
 
Bren10's Avatar
 
Join Date: Feb 2012
Location: mountain ash
Car: MG ZS
Posts: 2,705
Not sure if you have a mk1 or mk2 ZS but fuses are as follows.
Mk1 dash fuse number 23 covers radio, cigar lighter, clock and is 15 amp.
Mk2 dash fuse number 19 covers radio, cigar lighter, clock and is 15 amp.
Engine bay fuse box, fuse number 8 covers radio, clock and is also 15 amp same on mk1 or mk2.
Worth noting the clock display often fails on these cars, sometimes it's just a couple of pixels but more extreme cases display completely fails which will give you a backlit clock with no digits showing. Try fuse 8 in engine bay first and see if it helps.
Bren.
wappa5384 likes this.
Bren10 is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Couple of issues. RoverSRus MG ZS / Rover 45 & 400 2 18-01-2011 21:47
Newbie, with a couple of issues!! Clarry MG ZT / Rover 75 (Sponsored by Rimmer Bros) 2 12-08-2010 19:20
Couple of issues? jyorke MG ZT / Rover 75 (Sponsored by Rimmer Bros) 2 08-02-2010 13:58
Couple of issues bluecraigy MGF and MGTF (Sponsored by MGFnTFBITZ) 3 21-04-2009 11:03
couple of issues... fruit_n_veg MG ZS / Rover 45 & 400 0 22-01-2008 18:32

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome