[75 Radio issue] Hello, Help Please! - MG-Rover.org Forums
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 22 (permalink) Old 25-02-2017, 16:52 Thread Starter
Registered User
 
Join Date: Feb 2017
Location: Telford
Car: Rover 75 Tourer
Posts: 10
[75 Radio issue] Hello, Help Please!

hello I need some help I have brought a rover 75 connoisseur cdt touer, I'm having problems with the radio its the original radio with the trip planner and analogue tv, but the radio on this unit does not work so I have got a aftermarket radio but I cant find the right connections to connect from the car to the aftermarket radio can anyone help please? or know where that I can get a radio with cd player from that will work in my car?

thank you mark

I do have photos but they wont let me upload them for some reason

Last edited by MarkRover75; 25-02-2017 at 17:02.
MarkRover75 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 25-02-2017, 19:22
Registered User
 
Join Date: Feb 2017
Location: HEREFORD
Car: Rover 75 Tourer
Posts: 4
Send a message via AIM to G7AFM Send a message via MSN to G7AFM
iso plug

copy and paste the number below into ebay had to use one of these to fit aftermarket radio into my 75 tourer.not sure if you have the round pin block on you,re tourer so double check before ordering you may be able to get the adapter from a good auto electrics shop.

hope this helps.
phil

150671687237
G7AFM is offline  
post #3 of 22 (permalink) Old 25-02-2017, 19:41 Thread Starter
Registered User
 
Join Date: Feb 2017
Location: Telford
Car: Rover 75 Tourer
Posts: 10
have you got a email or number I send the photos to of my connections as it wont let me uploaded them on here and them what you sent look similar I think not 100%
MarkRover75 is offline  
 
post #4 of 22 (permalink) Old 25-02-2017, 19:46
Rover Lifestyle
 
Roverlike's Avatar
 
Join Date: Aug 2009
Location: Split, Croatia
Car: Rover 200 (95-99) 'Bubble Shape'
Posts: 10,565
If you want to upload photos on this forum you need to become a Supporter. Otherwise you can open an account on any picture hosting site like photobucket.com and from it present them here.
Roverlike is offline  
post #5 of 22 (permalink) Old 25-02-2017, 19:48
Registered User
 
Join Date: Feb 2017
Location: HEREFORD
Car: Rover 75 Tourer
Posts: 4
Send a message via AIM to G7AFM Send a message via MSN to G7AFM
best bet is to find car audio dealers in you,re location they will sort you out,only just joined the forum so don,t think i can pm you any details for email.
phil
G7AFM is offline  
post #6 of 22 (permalink) Old 25-02-2017, 19:57 Thread Starter
Registered User
 
Join Date: Feb 2017
Location: Telford
Car: Rover 75 Tourer
Posts: 10
ive uploaded to my sons photos bucket here's the link for the photos as you see there's a white connection and a blue one and the black box I want to connect to any help?

AdamTheGeek25's Recent Uploads | Photobucket
MarkRover75 is offline  
post #7 of 22 (permalink) Old 25-02-2017, 20:27
Registered User
 
Join Date: Apr 2004
Car: MGZS180,MGZR160,MGF VVC,MG Maestro T16, Rover 111
Posts: 5,650
Hi welcome to the forum

The 75 and ZT are roughly based on the BMW 5 series and have some unusual systems, however the blue and white plugs do not look like BMW so must be a hybrid system.

The black plug is standard DIN.

You need an adaptor, try autoleads.

James
Talkingcars is offline  
post #8 of 22 (permalink) Old 25-02-2017, 20:37 Thread Starter
Registered User
 
Join Date: Feb 2017
Location: Telford
Car: Rover 75 Tourer
Posts: 10
any links would be helpful, but the plugs say bmw on them you cant see it on the photo though
MarkRover75 is offline  
post #9 of 22 (permalink) Old 26-02-2017, 10:09 Thread Starter
Registered User
 
Join Date: Feb 2017
Location: Telford
Car: Rover 75 Tourer
Posts: 10
anyone help i did post a photo bucket link for the photos any help is appreciated
MarkRover75 is offline  
post #10 of 22 (permalink) Old 26-02-2017, 10:12
Registered User
 
Join Date: Apr 2004
Car: MGZS180,MGZR160,MGF VVC,MG Maestro T16, Rover 111
Posts: 5,650
Quote:
Originally Posted by Talkingcars View Post
You need an adaptor, try autoleads.
Welcome to Autoleads | Autoleads
Talkingcars is offline  
post #11 of 22 (permalink) Old 26-02-2017, 10:19 Thread Starter
Registered User
 
Join Date: Feb 2017
Location: Telford
Car: Rover 75 Tourer
Posts: 10
theres nothing there for them connections everyone I spoke to said they never seen them connections for a stereo even at Halfords looks like ill have to try and spilce the cables and getting no where with anything at moment
MarkRover75 is offline  
post #12 of 22 (permalink) Old 26-02-2017, 15:23
Registered User
 
Join Date: Apr 2004
Car: MGZS180,MGZR160,MGF VVC,MG Maestro T16, Rover 111
Posts: 5,650
http://www.armourautoretail.com/site...LowResWeb2.pdf
Page 95/96 and 115 or maybe even page 24.

Does yours have steering wheel switches?
Talkingcars is offline  
post #13 of 22 (permalink) Old 26-02-2017, 19:47
Registered User
 
Join Date: Jan 2006
Location: Cheshire
Car: MG TF 135, MG ZS+ 120
Posts: 9,764
Send a message via MSN to LeRich
Quote:
Originally Posted by MarkRover75 View Post
hello I need some help I have brought a rover 75 connoisseur cdt touer, I'm having problems with the radio its the original radio with the trip planner and analogue tv, but the radio on this unit does not work so I have got a aftermarket radio but I cant find the right connections to connect from the car to the aftermarket radio can anyone help please? or know where that I can get a radio with cd player from that will work in my car?

thank you mark

I do have photos but they wont let me upload them for some reason
Sounds like you have the Highline nav setup. Does it look like this?



It's a complicated BMW setup that combines different modules, most of which are in the boot. The radio module often fails due to water ingress.

It is possible to remove the nav head unit and install a standard aftermarket head unit. You will need to delve deep into the centre console to find the wiring connection of the audio system into the main loom (the connection will be the BMW type to suit the adaptor in the link below). Disconnect the nav loom from this connector and connect to the new head unit via an adaptor.

You will then need to reroute the aerial feed from the C-pillar or extend it from the old radio module in the boot. This is a faff that involves removing bits of interior trim to access and route the cable but is essential if you want a radio feed to your new head unit.

Your working nav modules can then be sold on ebay if so desired.

Quote:
Originally Posted by G7AFM View Post
150671687237
PC2-05-4 Rover 25 45 75 ISO Stereo Head Unit Harness Adaptor Wiring Loom Lead | eBay
LeRich is offline  
post #14 of 22 (permalink) Old 28-02-2017, 13:00 Thread Starter
Registered User
 
Join Date: Feb 2017
Location: Telford
Car: Rover 75 Tourer
Posts: 10
sorry for late reply yeah that is the stereo I have, but I have ordered a new one as my screen on mine has actually stopped working just a blank screen so ordered a new one last night
MarkRover75 is offline  
post #15 of 22 (permalink) Old 02-03-2017, 14:22 Thread Starter
Registered User
 
Join Date: Feb 2017
Location: Telford
Car: Rover 75 Tourer
Posts: 10
Exclamation

new one has came today but still having the same issue the radio still isn't coming on I have put a link to photos of what's in the boot don't know what is what for this car don't know much about cars myself so any help would be great just trying to find a way to get the radio to work that is all I want as got a long journey next weekend and who would want to travel down the motorway without a radio on?

but any help please message me
thank you
Mark

AdamTheGeek25's Recent Uploads | Photobucket
MarkRover75 is offline  
post #16 of 22 (permalink) Old 02-03-2017, 15:36
Registered User
 
Join Date: Jan 2017
Location: Aberdeen
Car: CityRover
Posts: 40
Is it possibly a blown fuse that's stopping the power?
NickChilds is offline  
post #17 of 22 (permalink) Old 02-03-2017, 15:49 Thread Starter
Registered User
 
Join Date: Feb 2017
Location: Telford
Car: Rover 75 Tourer
Posts: 10
We are only getting a orange menu with TV, SETTINGS, SCREEN OFF, AND TRIP COMPUTER.. we are checking the fuses as we speak
MarkRover75 is offline  
post #18 of 22 (permalink) Old 02-03-2017, 17:58
Registered User
 
Join Date: Jan 2006
Location: Cheshire
Car: MG TF 135, MG ZS+ 120
Posts: 9,764
Send a message via MSN to LeRich
There is very little processing that happens in the head unit. It's merely a 'front end' control interface with a screen and some buttons. It's the modules in the boot where the action happens so any problems can usually be traced to those.

I'd suggest you pay a visit to the 75 and ZT OC forum tbh as they will have greater knowledge of the system there.
LeRich is offline  
post #19 of 22 (permalink) Old 02-03-2017, 18:25 Thread Starter
Registered User
 
Join Date: Feb 2017
Location: Telford
Car: Rover 75 Tourer
Posts: 10
Question

To be honest mate I been on 3/4 different forums and they all keeps telling me to go to this page or this website etc but no one seems to reply or know anything
but I'm trying to fit a aftermarket stereo my self can any one help I have took middle bit out where unit would be I have came across these clips shown on photo bucket link can anyone tell me if these are what I need to use for aftermarket stereo?

http://s345.photobucket.com/user/Ada...=recent&page=1
MarkRover75 is offline  
post #20 of 22 (permalink) Old 02-03-2017, 20:53
Registered User
 
Join Date: Jan 2017
Location: Aberdeen
Car: CityRover
Posts: 40
Quote:
Originally Posted by MarkRover75 View Post
To be honest mate I been on 3/4 different forums and they all keeps telling me to go to this page or this website etc but no one seems to reply or know anything
but I'm trying to fit a aftermarket stereo my self can any one help I have took middle bit out where unit would be I have came across these clips shown on photo bucket link can anyone tell me if these are what I need to use for aftermarket stereo?

http://s345.photobucket.com/user/Ada...=recent&page=1
A lot of pages have gone down hill. Pity really. The Rover 75 and MG ZT Owners page on Facebook is good in my experience.
NickChilds is offline  
Reply

Bookmarks

Tags
radio, radio stations, rover, rover75

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Issue green53 MGF and MGTF (Sponsored by MGFnTFBITZ) 3 27-04-2014 13:15
Radio issue kristianhitchen MGF and MGTF (Sponsored by MGFnTFBITZ) 2 06-06-2011 17:07
Radio issue JIfill MG ZR / Rover 25, 200 & Streetwise 6 20-04-2010 13:30
Radio issue... goody MGF and MGTF (Sponsored by MGFnTFBITZ) 5 02-09-2007 11:05

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome