Bent Tappet Lifters,, CDTI - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 3 (permalink) Old 28-02-2017, 17:24 Thread Starter
Registered User
 
Join Date: Nov 2006
Location: rotherham
Car: mgzt190+,mgztcdti+mgzr105,kawasaki zx6r
Posts: 3,186
Bent Tappet Lifters,, CDTI

As title says,, could i have bent some lifters. , story goes,, I removed an overcompensating diesel injector, removed copper washer, sprayed and wiped the seat. sprayed quite a bit of cleaner/lube in there.. fitted new injector checked and started.. that particular injector missed for 5 seconds or so then kicked into life.. BUT, now i have a Tap,Tap,Tap like a tappet knock.. though the car runs drives perfect and injector balances are now + or - .50mm^3... Im now wondering if the initial start up has pushed 2 valves up hydraulically and bent a lifter?. now on the cdti m47 the "lifters" are under the cams, one side the hydraulic tappet and other side the valve with a roller in the middle..
Now im hoping someone will have heard of a lifter bending under the pressure now giving me a tappet knock..?

Last edited by keith8000_0; 28-02-2017 at 18:18.
keith8000_0 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 28-02-2017, 19:25
Registered User
 
Join Date: May 2008
Location: Scunthorpe
Car: Rover 400 (95-99)
Posts: 1,492
having just done a Peugeot with the same set up lifters cams followers , if the valves are compressed onto the cam and followers then the follower is designed to snap or break so a valve doesn't get bent .
It may be the injector that is making the tapping sound if not sealing correctly , or the injector itself could be faulty.
Andy400 is offline  
post #3 of 3 (permalink) Old 28-02-2017, 20:07 Thread Starter
Registered User
 
Join Date: Nov 2006
Location: rotherham
Car: mgzt190+,mgztcdti+mgzr105,kawasaki zx6r
Posts: 3,186
Quote:
Originally Posted by Andy400 View Post
having just done a Peugeot with the same set up lifters cams followers , if the valves are compressed onto the cam and followers then the follower is designed to snap or break so a valve doesn't get bent .
It may be the injector that is making the tapping sound if not sealing correctly , or the injector itself could be faulty.
Thanks for your response.. yes after i started it and heard the tapping,, i cleaned and put the origional injector back in. with new washer and its sealed ok.. might have to look into buying a couple of new followers and remove the cam cover to check for excessive play..
keith8000_0 is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cracked Tappet and Bent Valve Boss_oss_ss Diesel Forum! 6 13-06-2013 10:28
lifters smeagol_vvc MG ZR / Rover 25, 200 & Streetwise 5 31-08-2012 12:26
lifters stuart goodwin Rover 800 4 11-06-2012 17:04
new lifters simonruss MGF and MGTF (Sponsored by MGFnTFBITZ) 4 30-03-2012 10:16
zr lifters ZR Matt MG ZR / Rover 25, 200 & Streetwise 0 18-10-2011 18:18

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome