bonnet being diffucult at opening - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 4 (permalink) Old 23-05-2017, 15:43 Thread Starter
Registered User
 
Join Date: Nov 2015
Car: 75
Posts: 60
bonnet being diffucult at opening

idk how it's supposed to be but i really have to pull the bonnet release lever up to unlatch it, i almost aloways have to pull it up twice as it wont unlatch the first time even though i hear the thud, always with excessive force to the point that the bonnet release thingy has took set tilted up. should i be greaseing a part?
pingpong is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 23-05-2017, 17:35
Registered User
 
Join Date: May 2008
Location: Scunthorpe
Car: Rover 400 (95-99)
Posts: 1,557
i would remove it and give it a good clean as much as possible then give it a good greasing . close the latch and open it a few times while you have it off as well to work some of the grease into the pivot and latch points then wipe of any excesss and refit , also check the bonnet stops on the slam panel to see if they have been adjusted or moved and making the bonnet go tight to the catch on the lock,
Andy400 is offline  
post #3 of 4 (permalink) Old 24-05-2017, 16:10 Thread Starter
Registered User
 
Join Date: Nov 2015
Car: 75
Posts: 60
Quote:
Originally Posted by Andy400 View Post
i would remove it and give it a good clean as much as possible then give it a good greasing . close the latch and open it a few times while you have it off as well to work some of the grease into the pivot and latch points then wipe of any excesss and refit , also check the bonnet stops on the slam panel to see if they have been adjusted or moved and making the bonnet go tight to the catch on the lock,
do u know of a guide on how to remove it?, i can see the cabling on the side of the engine bay. the spring thingys on the bonnet is pretty sticky with stuff
pingpong is offline  
 
post #4 of 4 (permalink) Old 24-05-2017, 17:23
Registered User
 
Join Date: May 2008
Location: Scunthorpe
Car: Rover 400 (95-99)
Posts: 1,557
if i remember its a couple of 10 mm bolts that holds it on the panel ,i left the cable attached and worked on mine at the car , if i remember correctly the cable pulled and unclipped if had wanted to do it but mine just needed a quick clean and grease so didnt bother removing it totally , as you say the cable just unclips from the metal holders along the panel.( how ever mines a 400 not the zt or 75 so not sure if its covered by the bumper on yours sorry ).
Andy400 is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Opening bonnet? Meths MGF and MGTF (Sponsored by MGFnTFBITZ) 3 27-02-2013 12:04
bonnet not opening ZR-kris MG ZR / Rover 25, 200 & Streetwise 0 04-10-2011 16:19
Bonnet not opening. jambo98 MG ZT / Rover 75 (Sponsored by Rimmer Bros) 6 18-05-2010 20:36
bonnet not opening paul henery MG ZT / Rover 75 (Sponsored by Rimmer Bros) 4 08-07-2008 20:59
Bonnet Opening finly MGF and MGTF (Sponsored by MGFnTFBITZ) 6 22-12-2006 15:10

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome