MG ZS 180 MK2 Ignition Blue - MG-Rover.org Forums
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 6 (permalink) Old 01-08-2016, 01:36 Thread Starter
Supporter
 
Join Date: Feb 2016
Location: cumbria
Car: MG ZS
Posts: 23
MG ZS 180 MK2 Ignition Blue

Well I've finally got round to looking at my summer project.

I'm trying to ensure my 180 is perfect mechanically and electrically for next pride of long bridge meet.

I've given her a full major service.

the only thing that I thought may have been fixed in the service that wasn't (think I was trying to be over positive about this) is the fact that there seems to be a slight electrical fault on start up.

This fault hasn't recorded any fault codes.

what happens is if the car is started straight away (before the immobilizer is activated) it starts first time.
If you leave the car once unlocked and you sit in and wait for the immobilizer to activate then it won't play. the engine turns over as long as the key is turned and just won't actually fire.
it's like it's starved of fuel cam sensor fault for example. if you press unlock on the fob and start it with immobilizer off then no problem again.

the other thing is if you let the fuel pump finish it's prime before turning the key this also makes it turn over for ever and not fire up.

I went on a run to scotland in december with the car and it died i got lambda sensor error, low fuel pressure and random multiple misfire this coupled with the fact that i noticed a big surge in performance after brimming the tank helped me diagnose fuel pump failure after checking the flow rate of the pump.

so what is left can't be a fueling issue although if the pump stops priming then it wont fire up.

I'm starting to think it may be dreaded electric problems but just wondered if anyone else has any thoughts before I investigate further?

Regards,

Chris
chris2000 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-08-2016, 09:17
gnu
Supporter
 
gnu's Avatar
 
Join Date: Mar 2010
Location: Bristol
Car: MG ZS & Rover 200
Posts: 3,937
Blog Entries: 15
Garages
If you don't start quickly after unlocking the immobiliser cutting in is normal on the mk 2. If you then try to start, an attention getter will sound, and you just need to press the unlock on the fob before turning the key.

gnu
gnu is offline  
post #3 of 6 (permalink) Old 01-08-2016, 09:53
Registered User
 
Join Date: Jan 2011
Location: Hopelessly lost
Car: MG ZS
Posts: 2,969
Try changing the battery in the keyfob, i had all kinds of odd starting problems when the fob battery got low, changed the battery and solved the lot
Furryroo is offline  
 
post #4 of 6 (permalink) Old 01-08-2016, 11:40 Thread Starter
Supporter
 
Join Date: Feb 2016
Location: cumbria
Car: MG ZS
Posts: 23
Hi GNU,

The thing is if the siren sounds to say immobilizer is active and you either jingle the key near the pick up or press unlock then after turning the immobilizer off it turns over and over and over and won't fire. sorry I forgot to mention this.
It does it with both fobs.
chris2000 is offline  
post #5 of 6 (permalink) Old 04-08-2016, 21:24 Thread Starter
Supporter
 
Join Date: Feb 2016
Location: cumbria
Car: MG ZS
Posts: 23
does anyone have any ideas on the problem? :P

not sure where to start next lol
chris2000 is offline  
post #6 of 6 (permalink) Old 05-08-2016, 05:12
Rover Lifestyle
 
Roverlike's Avatar
 
Join Date: Aug 2009
Location: Split, Croatia
Car: Rover 200 (95-99) 'Bubble Shape'
Posts: 10,512
Your mentioning letting fuel pump finish priming, it will also not fire up. Actually for me letting immobilizer kick in and letting fuel pump to finish priming could mean the same issue as you are letting some time to pass before you try to start the engine.

You did not mention, if you changed the fuel pump or not?

Also have you checked the basics when you cannot turn the engine to fire: fuel, sparks?
Roverlike is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
Breaking MG ZR MK2 1.4 Ignition Blue skrib For Sale 0 08-10-2015 07:06
bargain mk2 180 ignition blue zswarrior MG ZS / Rover 45 & 400 3 13-02-2014 09:40
Brewsters Mk2 Ignition blue Brewsterpros MG ZR / Rover 25, 200 & Streetwise 38 12-02-2012 15:14
MG ZR 160 mk2 Ignition blue silver1back Cars For Sale 4 08-07-2011 10:07
Mg ZR MK2 1.8 120 in Ignition Blue DJceri_g Wanted 4 08-03-2009 11:39

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome