Removing Rover 25 factory fitted CD player - MG-Rover.org Forums
 
 
 
Go Back   MG-Rover.org Forums > Model Specific Forums > MG ZR / Rover 25, 200 & Streetwise

Reply
 
Thread Tools Rate Thread Display Modes
Old 27-06-2009, 14:12   #1
bmediauk
Registered User
 

Join Date: Oct 2008
Location: Birmingham UK
Car: Rover 25 Impression s 3dr
Posts: 63
Removing Rover 25 factory fitted CD player

I have managed to get my original factory fitted CD player out of it's fittings but just wondered if anyone knew how to release the big square plug from the back of the unit? A diagram on the unit shows to pull up the plastic clip which I obviously did. There seems to be no other way of freeing this plug from the unit itself. It is a case of brute force to pull it off?

Also, I stupidly pulled on the front of the CD player and the plug ribbon that connects the front panel to the circuit board came loose. Is there a quicker way of getting this slotted back in or do I have to dismantle the whole unit to get easier access to the circuit board?

The other option I suppose is to just fit a new CD player. Am I right in thinking all car stereos have the same connectors/plugs on the back and it should be a simple process of plug in and play?

Thanks in advance

Cheers
bmediauk is offline   Reply With Quote

Sponsored Links
Advertisement
 
Old 27-06-2009, 14:13   #2
BLMC
Registered User
 

Join Date: Mar 2002
Location: GBR
Car: -
Posts: 24,783
What type of connection or what year is the car.
BLMC is offline   Reply With Quote

Old 27-06-2009, 14:14   #3
soooperspeed
Registered User
 

Join Date: May 2007
Location: wales
Car: rover R200 wid loadza sweet modz....
Posts: 1,220
Blog Entries: 1
there is a small plastic pin at the top of the connector if it has snapped thenuse a small flat head in the groove to press it down and it will slide out



or this


Last edited by soooperspeed; 27-06-2009 at 14:16. Reason: photo
soooperspeed is offline   Reply With Quote

Old 27-06-2009, 14:16   #4
BLMC
Registered User
 

Join Date: Mar 2002
Location: GBR
Car: -
Posts: 24,783
Quote:
Originally Posted by soooperspeed View Post
there is a small plastic pin at the top of the connector if it has snapped thenuse a small flat head in the groove to press it down and it will slide out

I'm guessing he has the BMW wiring not ISO.
BLMC is offline   Reply With Quote

Old 27-06-2009, 14:17   #5
bmediauk
Registered User
 

Join Date: Oct 2008
Location: Birmingham UK
Car: Rover 25 Impression s 3dr
Posts: 63
Quote:
Originally Posted by Roverman View Post
What type of connection or what year is the car.
It's an 02 plate
bmediauk is offline   Reply With Quote

Old 27-06-2009, 14:18   #6
soooperspeed
Registered User
 

Join Date: May 2007
Location: wales
Car: rover R200 wid loadza sweet modz....
Posts: 1,220
Blog Entries: 1
ok so its like this then

soooperspeed is offline   Reply With Quote

Old 27-06-2009, 14:18   #7
bmediauk
Registered User
 

Join Date: Oct 2008
Location: Birmingham UK
Car: Rover 25 Impression s 3dr
Posts: 63
Quote:
Originally Posted by Roverman View Post
I'm guessing he has the BMW wiring not ISO.
Yeah, that is similar to the connector I have on my unit. Thanks for the advice on the small plastic pin.I'll try that
bmediauk is offline   Reply With Quote

Old 27-06-2009, 14:18   #8
BLMC
Registered User
 

Join Date: Mar 2002
Location: GBR
Car: -
Posts: 24,783
It's probably bmw.
Just lift the plastic clip as you stated and then pull.
BLMC is offline   Reply With Quote

Old 27-06-2009, 14:19   #9
bmediauk
Registered User
 

Join Date: Oct 2008
Location: Birmingham UK
Car: Rover 25 Impression s 3dr
Posts: 63
Quote:
Originally Posted by soooperspeed View Post
ok so its like this then

Yep, that's the one :-)
bmediauk is offline   Reply With Quote

Old 27-06-2009, 14:19   #10
soooperspeed
Registered User
 

Join Date: May 2007
Location: wales
Car: rover R200 wid loadza sweet modz....
Posts: 1,220
Blog Entries: 1
and this sorta player



images courtesy of 220deano


http://forums.mg-rover.org/showthread.php?t=273472
soooperspeed is offline   Reply With Quote

Old 27-06-2009, 14:21   #11
soooperspeed
Registered User
 

Join Date: May 2007
Location: wales
Car: rover R200 wid loadza sweet modz....
Posts: 1,220
Blog Entries: 1
ok see the bottom there is a small clips and just put a flat head there and wiggle it


tell me if you are taking it out

is this on the end of the wires or is it adapted from the iso system wires
cos if it is just take the iso one loose that is all you need
soooperspeed is offline   Reply With Quote

Old 27-06-2009, 14:22   #12
bmediauk
Registered User
 

Join Date: Oct 2008
Location: Birmingham UK
Car: Rover 25 Impression s 3dr
Posts: 63
Quote:
Originally Posted by soooperspeed View Post
and this sorta player



images courtesy of 220deano


http://forums.mg-rover.org/showthread.php?t=273472
That's the exact one :-) I just need to try and get that ribbon type plug back into the front now which looks like a bit of a mission. (when I say ribbon type I mean it is similar to the types of plugs your get inside a computer that connects the battery to the hard drive)
bmediauk is offline   Reply With Quote

Old 27-06-2009, 14:24   #13
soooperspeed
Registered User
 

Join Date: May 2007
Location: wales
Car: rover R200 wid loadza sweet modz....
Posts: 1,220
Blog Entries: 1
so you have damaged the front of the cd player taking it out isi


photos

???
soooperspeed is offline   Reply With Quote

Old 27-06-2009, 14:24   #14
bmediauk
Registered User
 

Join Date: Oct 2008
Location: Birmingham UK
Car: Rover 25 Impression s 3dr
Posts: 63
Quote:
Originally Posted by soooperspeed View Post
ok see the bottom there is a small clips and just put a flat head there and wiggle it


tell me if you are taking it out

is this on the end of the wires or is it adapted from the iso system wires
cos if it is just take the iso one loose that is all you need
Thanks for the advice. I'll try that now
bmediauk is offline   Reply With Quote

Old 27-06-2009, 14:25   #15
bmediauk
Registered User
 

Join Date: Oct 2008
Location: Birmingham UK
Car: Rover 25 Impression s 3dr
Posts: 63
I'll post some photo's in sec

Cheers
bmediauk is offline   Reply With Quote

Old 27-06-2009, 14:36   #16
bmediauk
Registered User
 

Join Date: Oct 2008
Location: Birmingham UK
Car: Rover 25 Impression s 3dr
Posts: 63
http://img190.imageshack.us/img190/6796/27062009611.jpg

This is the connector that has come loose

http://img29.imageshack.us/img29/4667/27062009612.jpg

Back of the unit
bmediauk is offline   Reply With Quote

Old 27-06-2009, 14:41   #17
soooperspeed
Registered User
 

Join Date: May 2007
Location: wales
Car: rover R200 wid loadza sweet modz....
Posts: 1,220
Blog Entries: 1
lol you need to click the rezise box when useing imageshack set it to 640 by 480

like this



and that is the ribbon cable going to the circuit board you are going to have to remove the top ov the stereo and reslide it into the plug (black or brown looks like a minature card port
soooperspeed is offline   Reply With Quote

Old 27-06-2009, 14:44   #18
bmediauk
Registered User
 

Join Date: Oct 2008
Location: Birmingham UK
Car: Rover 25 Impression s 3dr
Posts: 63
Quote:
Originally Posted by soooperspeed View Post
lol you need to click the rezise box when useing imageshack set it to 640 by 480

like this

[img]http://img10.imageshack.us/img10/6796/27062009611.jpg

and that is the ribbon cable going to the circuit board you are going to have to remove the top ov the stereo and reslide it into the plug (black or brown looks like a minature card port
Oh what fun! :-) I'll try and get the plug off the back first to release the unit freely and then work at getting the lid off the thing. Thanks for you help
bmediauk is offline   Reply With Quote

Old 27-06-2009, 14:46   #19
soooperspeed
Registered User
 

Join Date: May 2007
Location: wales
Car: rover R200 wid loadza sweet modz....
Posts: 1,220
Blog Entries: 1
its k

soooperspeed is offline   Reply With Quote

Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rover 25 Factory fitted CD player help bmediauk MG ZR / Rover 25, 200 & Streetwise 2 02-06-2009 15:06
Removing the Stock Rover 45 CD Player munk3h MG ZS / Rover 45 & 400 5 02-05-2008 12:44
6 CD player/magazine - what make is fitted to the Rover 75 ? steve46 MG ZT / Rover 75 (Sponsored by Rimmer Bros) 2 31-05-2005 15:43
Rover 75 - Removing the factory-fit CD changer from my glove box!! bigwils In-Car Audio, Entertainment, Sat Nav etc... 2 12-05-2005 01:36
Removing Rover 45 CD Player Rover45Guy In-Car Audio, Entertainment, Sat Nav etc... 6 11-01-2004 15:26


All times are GMT. The time now is 06:15.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
ShowCase, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.