Heater Fan speed switch - MG-Rover.org Forums
 
 
 
Go Back   MG-Rover.org Forums > Model Specific Forums > MG ZR / Rover 25, 200 & Streetwise

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-07-2009, 13:29   #1
Brum200
Registered User
 

Join Date: Aug 2006
Location: Birmingham
Car: Rover 200 (95-99) 'Bubble Shape'
Posts: 17
Heater Fan speed switch

Hi, I've searched on the forum briefly for this answer, came to no avail.

On my Rover 200 bubble, My heater fan speeds doesnt work at all, (The knob with 1234 on it) I've changed the switch itself from an known working one on another rover and have tested working on that car.

Fitted said switch from working car to mine and it still doesnt work at all??Can anyone shed any light on this?

It currently has suspected HGF but I would like to get the heater fan working before changing the HG after a garage "bodged" an HG fix on it.

Any help would be apprecitated.

Cheers
Andy
Brum200 is offline   Reply With Quote Quick reply to this message

Sponsored Links
Advertisement
 
Old 02-07-2009, 13:31   #2
HotTubRepairer
Registered User
 

Join Date: Jan 2007
Location: Lincolnshire
Car: Astravan 165
Posts: 12,190
Send a message via MSN to HotTubRepairer
I'd be more concerned about fixing the HG myself. Anyway, do all of the speeds not work? Did you check the fuse?
HotTubRepairer is offline   Reply With Quote Quick reply to this message

Old 02-07-2009, 13:41   #3
MyMgCar.com
Registered User
 

Join Date: Feb 2007
Location: London/Liverpool
Car: R2h1zZle Vvf0sh1Zzle!!
Posts: 8,210
Send a message via MSN to MyMgCar.com Send a message via Skype™ to MyMgCar.com
When you say swapped the "switch" is this just the knob on top that you use to turn the dial? Does the dials turn to position 1,2,3,4 and do you get any air at any speeds?

If you dont get air at speeds 1 and 2 its most likely your heater resistor pack is gone. If you dont get hot air on 4, then get the garage to clean out the pipes and check the "bodged" HG job they did.
MyMgCar.com is offline   Reply With Quote Quick reply to this message

Old 02-07-2009, 22:54   #4
Brum200
Registered User
 

Join Date: Aug 2006
Location: Birmingham
Car: Rover 200 (95-99) 'Bubble Shape'
Posts: 17
Quote:
Originally Posted by HotTubRepairer View Post
I'd be more concerned about fixing the HG myself. Anyway, do all of the speeds not work? Did you check the fuse?
Do they stop working when the HG goes? Everythings been checked, fuses n fan switches, none of the speeds work at all.
Brum200 is offline   Reply With Quote Quick reply to this message

Old 02-07-2009, 22:56   #5
Brum200
Registered User
 

Join Date: Aug 2006
Location: Birmingham
Car: Rover 200 (95-99) 'Bubble Shape'
Posts: 17
Quote:
Originally Posted by YTL2000 View Post
When you say swapped the "switch" is this just the knob on top that you use to turn the dial? Does the dials turn to position 1,2,3,4 and do you get any air at any speeds?

If you dont get air at speeds 1 and 2 its most likely your heater resistor pack is gone. If you dont get hot air on 4, then get the garage to clean out the pipes and check the "bodged" HG job they did.
I dont get any air at any speeds the switch clicks freeley.

Wont go to the garage as bunch of knobs, try argue n they resort to threatening.
Brum200 is offline   Reply With Quote Quick reply to this message

Old 02-07-2009, 23:40   #6
Olly650
Registered User
 

Join Date: Jan 2009
Location: Darlington
Car: 420 TD Exec
Posts: 294
Have you checked the heater resistor pack, under the glovebox?
Olly650 is offline   Reply With Quote Quick reply to this message

Old 02-07-2009, 23:48   #7
HotTubRepairer
Registered User
 

Join Date: Jan 2007
Location: Lincolnshire
Car: Astravan 165
Posts: 12,190
Send a message via MSN to HotTubRepairer
Quote:
Originally Posted by Olly650 View Post
Have you checked the heater resistor pack, under the glovebox?
Surely that would be rare for the resistors to stop the fan working on all speeds at the same time?
HotTubRepairer is offline   Reply With Quote Quick reply to this message

Old 02-07-2009, 23:56   #8
technozen
Mmmm....Rover..
 
technozen's Avatar
 

Join Date: Mar 2002
Location: Brighton.
Car: 200vi & Freelander XEDi
Posts: 10,190
Send a message via MSN to technozen
If the resistor pack fails completely the fan will always still operate on position 4 - full speed.

Does the cigarette lighter work? It shares the same relay and fuse as the fan for it's 12 volt supply.

Check Fuse 7 (20 amp) in the engine bay fusebox, Fuse 18 (10 amp) in the drivers fusebox, this provides power for the relay or the relay itself which is located behind the glovebox and is a sod to get to!

The fan motor can fail but it is rarely the fault.
__________________
I offer FREE engine/alarm diagnostics and fob coding (incl. Pektron fobs) to mg-rover.org Supporters - details here.
Fob not working? Common faults and fixes here.
Pektron BCU/SCU Faulty? This may be of some help. Full SCU programming and repair services available.
Discounted SCU/BCU Full Relay Replacement Service - only for Supporters - details here
Replacement relays for the Pektron SCU available - .org Supporters buy 4, 5th is free - PM for details.
technozen is offline   Reply With Quote Quick reply to this message

Old 21-08-2009, 13:41   #9
larryMG
Registered User
 

Join Date: Jul 2009
Location: Glasgow
Car: MG ZR
Posts: 24
Send a message via MSN to larryMG
I've got the same kind of problem. My heater dosn't work on 1&2 3 & 4 work though. Also the heater rod has like sezied up and wont change from heat to cold


help

cheers
larryMG is offline   Reply With Quote Quick reply to this message

Old 21-08-2009, 14:34   #10
Popeye 89
Registered User
 

Join Date: Jul 2009
Location: Northampton
Car: MG ZR160
Posts: 7,195
Send a message via MSN to Popeye 89
hmm thats kinda strange. rather than start a new thread i thought id use this one as i have no fan on speeds 1 and 2, just 3 and 4. cigarette lighter still works though
Popeye 89 is offline   Reply With Quote Quick reply to this message

Old 21-08-2009, 14:40   #11
minesarover
Registered User
 

Join Date: Mar 2009
Location: Mid Glamorgan.........@@@@@@@ SYKES PICKAVANT ACR4 IMAP & IKEYS @@@@@@@
Car: Rover 420 sdi ,Mitsubishi Shogun 2.8 LWB,BMW Z3, Ford Transit, MG ZSTD
Posts: 2,200
Quote:
Originally Posted by one_eyed_R25 View Post
hmm thats kinda strange. rather than start a new thread i thought id use this one as i have no fan on speeds 1 and 2, just 3 and 4. cigarette lighter still works though
Your problem is the heater resistor pack behind the glove box top of fan housing 2 screws.
minesarover is offline   Reply With Quote Quick reply to this message

Old 21-08-2009, 14:44   #12
Popeye 89
Registered User
 

Join Date: Jul 2009
Location: Northampton
Car: MG ZR160
Posts: 7,195
Send a message via MSN to Popeye 89
does this have to be replaced or can it be repaired?
Popeye 89 is offline   Reply With Quote Quick reply to this message

Old 21-08-2009, 15:00   #13
larryMG
Registered User
 

Join Date: Jul 2009
Location: Glasgow
Car: MG ZR
Posts: 24
Send a message via MSN to larryMG
I'll have look is it easy to find? And how much would a new one cost?
larryMG is offline   Reply With Quote Quick reply to this message

Old 21-08-2009, 15:49   #14
rikernumber1
Registered User
 

Join Date: Dec 2006
Location: Whitstable
Car: Rover 211 1.1 8v SE
Posts: 130
Folks on here sometimes supply them, or try eBay. Around the 5 mark is reasonable - you may get them cheaper.
rikernumber1 is offline   Reply With Quote Quick reply to this message

Old 21-08-2009, 15:55   #15
Popeye 89
Registered User
 

Join Date: Jul 2009
Location: Northampton
Car: MG ZR160
Posts: 7,195
Send a message via MSN to Popeye 89
when you take out the glovebox its right in front of you with a 4 pin plug and 2 x 6mm bolts
Popeye 89 is offline   Reply With Quote Quick reply to this message

Old 21-08-2009, 16:00   #16
Richy
Registered User
 

Join Date: Aug 2007
Location: Gloucestershire
Car: RZ5
Posts: 9,876
Quote:
Originally Posted by rikernumber1 View Post
Folks on here sometimes supply them, or try eBay. Around the 5 mark is reasonable - you may get them cheaper.
Mr. Technozen sells them.
Richy is offline   Reply With Quote Quick reply to this message

Old 21-08-2009, 16:08   #17
larryMG
Registered User
 

Join Date: Jul 2009
Location: Glasgow
Car: MG ZR
Posts: 24
Send a message via MSN to larryMG
Cheers i'll check it out tonight n get one from him if thats what it is.
larryMG is offline   Reply With Quote Quick reply to this message

Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater fan switch cherokee MG ZR / Rover 25, 200 & Streetwise 2 16-01-2009 20:29
Heater Fan Switch Robert.Nicholls MG ZS / Rover 45 & 400 3 21-05-2007 17:51
Heater Fan Switch The Gas Man MG ZR / Rover 25, 200 & Streetwise 1 28-02-2007 22:45
Rover 200 heater fan, Not resistor or switch. Help! gadget32 Others 8 14-01-2006 13:32
Mk2 416 Heater fan switch! hughjohnson MG ZS / Rover 45 & 400 7 19-12-2002 19:08


All times are GMT. The time now is 03:56.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
ShowCase, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.