Rover 25 heater not working - MG-Rover.org Forums
 
 
 
Go Back   MG-Rover.org Forums > Introduce yourself

Reply
 
Thread Tools Rate Thread Display Modes
Old 18-08-2010, 19:31   #1
DrTrciky
Registered User
 

Join Date: Aug 2010
Car: Rover 25
Posts: 11
Rover 25 heater not working

Hi, I have recently bought a 54 plate, 40K on the clock, Rover 25 1.4. Within a week I needed to replace the head gasket and also the water pump. Everything seemed OK, but one chilly night I tried the heater and all I have got is cold air blowing. I have read other posts and have tried to bleed the air but nothing seems to work, all the hoses seem intact no leaks, when I try and use the bleed screw I just get coolant flowing through it.

Any suggestions welcome.
DrTrciky is offline   Reply With Quote Quick reply to this message

Sponsored Links
Advertisement
 
Old 21-08-2010, 19:22   #2
steve-d
Registered User
 

Join Date: Aug 2010
Car: Rover 45
Posts: 3
Exclamation Heater blowing cold

Hi.
I'm new to this forum and I am not sure this is the right place for technical questions but here goes!
My wife's ZR 105 had a similar problem with only cold air from the heater. Upon checking, I found no coolant in the header tank - not a desirable thing on any engine, never mind a K series. I topped up the tank, but the next day after only 6 miles the tank was empty again. As a matter of routine I replaced the head gasket and water pump ( the parts are cheap and the procedure is straightforwards ) but the next day I found the tank to be empty again!
I took the car for a short drive and after a couple of miles I could hear something going on under the bonnet. The header tank was full to the cap with boiling coolant. The car, an 04 plate, was fitted with the later type of heater hose with the Saab pressure relief by-pass valve. This valve is supposed to open to allow coolant to flow along the by-pass hose to the thermostat when the heater valve is closed. I found that it had disintegrated internally and the rubber button inside had become detached and was totally blocking the inlet to the thermostat. On the K series engine, the thermostat depends on hot coolant flowing down the by-pass hose before it opens to allow the main coolant flow through the radiator. A blocked by-pass hose is a potentially disastrous event for the engine.
A replacement hose with the Saab valve is around 55 from Rimmer Brothers. I fixed my wifes car with the heater hose off an earlier Rover 25 without the valve from a breakers. He didn't charge me for it either as I bought some Rover 45 bits at the same time!
Your problem could be the same, as I understand that the Saab valve is unreliable. Drain the coolant and remove the valve. If you can poke a pencil or similar through it without any obstruction, it is likely that it has failed in the same way as my wife's car, and that the internal parts have worked their way towards the thermostat housing, possibly blocking the flow.
I hope this info is of use.
Best regards,
Steve
steve-d is offline   Reply With Quote Quick reply to this message

Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rover 200 heater not working ramseyrover MG ZR / Rover 25, 200 & Streetwise 6 01-03-2010 11:02
Rover 75 Heater Not Working TopGearRules MG ZT / Rover 75 (Sponsored by Rimmer Bros) 5 20-12-2009 23:03
Rover 200 Heater not working badgerboy MG ZR / Rover 25, 200 & Streetwise 27 08-03-2008 08:38
Rover 25 51 plate heater not working after upgrade on engine tony123 MG ZR / Rover 25, 200 & Streetwise 3 04-12-2005 08:57
rover 414si heater not working right Jem. Others 1 17-01-2005 21:09


All times are GMT. The time now is 00:44.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
ShowCase, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.