mg zr central locking problem - please help! - MG-Rover.org Forums
 
 
 
Go Back   MG-Rover.org Forums > Model Specific Forums > MG ZR / Rover 25, 200 & Streetwise

Reply
 
Thread Tools Rate Thread Display Modes
Old 27-07-2011, 15:10   #1
cogsys
Registered User
 

Join Date: Jul 2011
Car: MG ZR
Posts: 11
mg zr central locking problem - please help!

Hi, all a bit new to this, just joined the forum today.

Seen lots of good stuff here in the past so hoping someone can help.

I've got an MGZR 2004 - problem is the central locking isn't working properly. It opens off the remote fine, but will not lock of the remote. to lock it I have to push down the pass side door knob then get out and lock the drivers door from the key (which arms the alarm ok) then lock the boot.

Would really appreciate any help or advice

cheers all
cogsys is offline   Reply With Quote Quick reply to this message

Sponsored Links
Advertisement
 
Old 27-07-2011, 15:20   #2
perks68
Registered User
 

Join Date: Feb 2009
Location: East London
Car: 160
Posts: 1,403
Blog Entries: 3
Quote:
Originally Posted by cogsys View Post
Hi, all a bit new to this, just joined the forum today.

Seen lots of good stuff here in the past so hoping someone can help.

I've got an MGZR 2004 - problem is the central locking isn't working properly. It opens off the remote fine, but will not lock of the remote. to lock it I have to push down the pass side door knob then get out and lock the drivers door from the key (which arms the alarm ok) then lock the boot.

Would really appreciate any help or advice

cheers all

Check the rear tailgate loom first, open the tail gate, right side and you will see a rubber boot thing the loom breaks and chaffs in there...

Perks68
perks68 is offline   Reply With Quote Quick reply to this message

Old 27-07-2011, 15:33   #3
cogsys
Registered User
 

Join Date: Jul 2011
Car: MG ZR
Posts: 11
cheers Perks, talk about a fast response - nice one. i'll have a look later.
cogsys is offline   Reply With Quote Quick reply to this message

Old 27-07-2011, 15:54   #4
Keefo
Registered User
 

Join Date: Feb 2009
Location: Oldham, Manchester
Car: Ford Focus ST3
Posts: 6,558
Send a message via MSN to Keefo
Yeah the Boot loom can be a ***** and cause all kinds of problems like this!

Just take off the rubber boot on the top right of the boot lid when open, check for broken/worn wires and just tidy them up/repair

also make sure your FOB isnt abit gunky or have a broken button!

Can you hear the button itself actually click?
Keefo is offline   Reply With Quote Quick reply to this message

Old 30-07-2011, 09:49   #5
cogsys
Registered User
 

Join Date: Jul 2011
Car: MG ZR
Posts: 11
Hi, ive had a look at the tailgate loom as suggested this morning, all seems ok, no bare or broken wires, so its back to the drawing board for me. Can anyone offer any more suggestions - cheers
cogsys is offline   Reply With Quote Quick reply to this message

Old 30-07-2011, 10:01   #6
lovel
T4 Diagnostics
 
lovel's Avatar
 

Join Date: Feb 2005
Location: Aberdeenshire
Car: R40, P6, Jewel, CB40, Imp, R56
Posts: 818
Garages
If you have the Oval shaped fob then you may have an issue with the BCU relay and/or driver.

Member Technozen has posted a how to on the subject.

http://forums.mg-rover.org/showthread.php?t=384938
lovel is online now   Reply With Quote Quick reply to this message

Old 30-07-2011, 13:08   #7
cogsys
Registered User
 

Join Date: Jul 2011
Car: MG ZR
Posts: 11
Unhappy

thanks lovel,

I've followed that link, sure it's useful but it's all a bit beyond me i'm afraid. I couldn't even locate the EBU/SCU let alone change relays - D'oh !! would be interested to know where it is though ?? if there's no other possible (simplier -LOL) things I can check then I guess i'm goona have to live with it.
At the risk of sounding like a complete muppet, i was lookin in my trusty haines manual and cannot see the EBU in the wiring diagram for central locking. confused !!
cogsys is offline   Reply With Quote Quick reply to this message

Old 31-07-2011, 17:09   #8
MGR_Petrolhead
Registered User
 

Join Date: Nov 2005
Location: Nottinghamshire
Car: 2014 MG3 Style Lux and 2000 Rover Mini Cooper Sportspack
Posts: 16,492
Blog Entries: 5
Send a message via MSN to MGR_Petrolhead
Quote:
Originally Posted by cogsys View Post
thanks lovel,

I've followed that link, sure it's useful but it's all a bit beyond me i'm afraid. I couldn't even locate the EBU/SCU let alone change relays - D'oh !! would be interested to know where it is though ?? if there's no other possible (simplier -LOL) things I can check then I guess i'm goona have to live with it.
At the risk of sounding like a complete muppet, i was lookin in my trusty haines manual and cannot see the EBU in the wiring diagram for central locking. confused !!
Hi,

The BCU is a small box located behind the glovebox on later 25/ZRs. If your car does not have air conditioning, it will be easier to get at.
MGR_Petrolhead is offline   Reply With Quote Quick reply to this message

Old 31-07-2011, 18:25   #9
perks68
Registered User
 

Join Date: Feb 2009
Location: East London
Car: 160
Posts: 1,403
Blog Entries: 3
Quote:
Originally Posted by cogsys View Post
Hi, ive had a look at the tailgate loom as suggested this morning, all seems ok, no bare or broken wires, so its back to the drawing board for me. Can anyone offer any more suggestions - cheers

Buddy, don't dismiss by it looks ok...Did you pull off back the rubber boot, exposing the wire loom inside the boot..Don't just check the front and back side of the boot-use a bit of fairy in it and slide it back..

Perks68
perks68 is offline   Reply With Quote Quick reply to this message

Old 01-08-2011, 17:00   #10
cogsys
Registered User
 

Join Date: Jul 2011
Car: MG ZR
Posts: 11
Cheers perks, I did have a good look at the exposed wires mate. A few chaffing marks but no broken or bare wires. I think - as suggested by others - the problem lies within the central locking relay in the bcu/scu. Followed a link posted by someone above, helpful but i'm worried about doing more harm than good. I never used a soldering iron before, if I could get a relacement relay, would need some guideance their. I guess to get the old relay off the board I just use some heat from the iron? Who knows! Would also need/appreciate any tips on soldering the new relay to the board. Gonna have a think whether to tackle this job, would like it sorted though cos othe than this my zr in top nick 04 plate only just over 20k on the clock had it since new
cogsys is offline   Reply With Quote Quick reply to this message

Old 01-08-2011, 18:06   #11
Lovewise
Registered User
 

Join Date: Mar 2011
Car: ZR TD 115+
Posts: 962
Before doing all that I would take the door card off to have a look inside, could be a mechanical fault. When I did mine there was stuff like chewing gum plastered all over the metal rod that the pin is attached too.

This made it really sticky and the motor was unable to move the pin as there was bit of foam the rod was sticking too, confused the hell out of the central locking!

Plastering a load of grease in there wouldnt hurt too, the above might not be the cause, its only a guess though.
Lovewise is offline   Reply With Quote Quick reply to this message

Old 01-08-2011, 18:42   #12
lovel
T4 Diagnostics
 
lovel's Avatar
 

Join Date: Feb 2005
Location: Aberdeenshire
Car: R40, P6, Jewel, CB40, Imp, R56
Posts: 818
Garages
Quote:
Originally Posted by cogsys View Post
Cheers perks, I did have a good look at the exposed wires mate. A few chaffing marks but no broken or bare wires. I think - as suggested by others - the problem lies within the central locking relay in the bcu/scu. Followed a link posted by someone above, helpful but i'm worried about doing more harm than good. I never used a soldering iron before, if I could get a relacement relay, would need some guideance their. I guess to get the old relay off the board I just use some heat from the iron? Who knows! Would also need/appreciate any tips on soldering the new relay to the board. Gonna have a think whether to tackle this job, would like it sorted though cos othe than this my zr in top nick 04 plate only just over 20k on the clock had it since new
You could possibly remove the BCU and send to Technozen for checking or repair?
lovel is online now   Reply With Quote Quick reply to this message

Old 01-08-2011, 21:09   #13
cogsys
Registered User
 

Join Date: Jul 2011
Car: MG ZR
Posts: 11
?

tThanks lovewise - already had a nose behind the drivers door card and things seemed ok. Guess I should maybe check pass side though.

lovel - that might be a good option to contact technozen. As im new to this forum. Is there a way I can contact/message him direct?
cogsys is offline   Reply With Quote Quick reply to this message

Old 01-08-2011, 21:58   #14
lovel
T4 Diagnostics
 
lovel's Avatar
 

Join Date: Feb 2005
Location: Aberdeenshire
Car: R40, P6, Jewel, CB40, Imp, R56
Posts: 818
Garages
Quote:
Originally Posted by cogsys View Post
lovel - that might be a good option to contact technozen. As im new to this forum. Is there a way I can contact/message him direct?
Just PM him (private message) and if he is around he should get back to you.

Either in your User CP on top left or Private Messages which is highlighted on the top right adjacent to your user name.
lovel is online now   Reply With Quote Quick reply to this message

Old 01-08-2011, 22:34   #15
technozen
Mmmm....Rover..
 
technozen's Avatar
 

Join Date: Mar 2002
Location: Brighton.
Car: 200vi & Freelander XEDi
Posts: 10,188
Send a message via MSN to technozen
It sounds like one side of the central locking relay within the SCU has failed.

I can supply replacement relays to fix this problem (discounted for .org Supporters) or can replace the relay(s) for you if you want to send me the SCU.

PM me or send an email.... technozen@ntlworld.com
__________________
I offer FREE engine/alarm diagnostics and fob coding (incl. Pektron fobs) to mg-rover.org Supporters - details here.
Fob not working? Common faults and fixes here.
Pektron BCU/SCU Faulty? This may be of some help. Full SCU programming and repair services available.
Discounted SCU/BCU Full Relay Replacement Service - only for Supporters - details here
Replacement relays for the Pektron SCU available - .org Supporters buy 4, 5th is free - PM for details.
technozen is offline   Reply With Quote Quick reply to this message

Old 20-05-2013, 12:42   #16
Scoobystira
Registered User
 

Join Date: May 2013
Car: MG ZR
Posts: 4
Hiya guys just registered
Bought the missus a 2004 zr recently and all was fine until yesterday when the remote central locking stopped working, similar problems to the guy above except with the wifes car when you press the fob im getting a clicking noise coming from the boot, il check the loom tonight, is there anything else this clicking noise could be coming from
Scoobystira is offline   Reply With Quote Quick reply to this message

Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the MG-Rover.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mg zr central locking problem - help !! cogsys MG ZR / Rover 25, 200 & Streetwise 2 29-07-2011 20:06
mg zr central locking problem hibee zr MG ZR / Rover 25, 200 & Streetwise 5 09-12-2010 15:45
Central locking problem on 2003 MG ZR 105+ zanhar25 MG ZR / Rover 25, 200 & Streetwise 4 12-10-2009 15:24
MG ZR Central Locking Problem. Jim2402 MG ZR / Rover 25, 200 & Streetwise 12 10-01-2007 22:05
MG ZR - Problem With Central Locking tommyg2688 MG ZR / Rover 25, 200 & Streetwise 4 22-01-2006 19:47


All times are GMT. The time now is 21:30.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
ShowCase, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.