MG-Rover.org Forums banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
10,841 Posts
Discussion Starter #1 (Edited)
This is a thread designed to give owners information for some of the more common problems shared between drivers.
If you have a problem and need information it could be in here.

Alternatively, if you have had a problem and have fixed it, please private message me with information and i will post it up.
Any information is welcome, no problem to big or too small!

Regards Stu C
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #2
Member - Kamal

Loss of boost/performance is also a symptom of a split intercooler hose.
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #3
Member - SDI_TIM

Check engine light comes on and severe lack of performance above 2000(ish) rpm = chafed wiring to the needle lift sensor on injector number 1, or dirty/faulty sensor
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #4
Member - SDI_TIM

Car revs to 1250rpm, accelerator pedal makes no difference = faulty throttle position sensor (TPS)
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #5
Member - SDI_TIM

Check engine light comes on and engine revs erratically - check crank position sensor (CPS) and its wiring
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #6
Member - SDI_TIM

Car hits a brick wall when accelerating hard, especially in 3rd/4th/5th - boost cut activated. Either faulty MAP sensor reporting boost too high (most likely if if untuned), or boost set too high (more likely if tuned) = lower boost by adjusting turbo wastegate actuator.
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #7
Member - SDI_TIM

On older models e.g. the bubble 200's/400's/600's - car is sluggish, no excess smoking from exhaust = check brake light bulbs, check brake switch operation, check for chafed wires in tailgate for chafing causing shorting out of the brake circuit.
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #8
Member SDI_TIM

Car is a nightmare to start, smokes a bit after starting, and then runs fine all day - check fuel pump timing (known to happen on older intercooled models e.g. 200/400/600 DI/SDIGSDI)
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #9
Member SDI_TIM

Difficult starting from cold, runs lumpy for a few seconds with some smoke, fine after that, worse in cold weather = check glow plugs, relay and power feed connections. Also, coolant temperature sensor sends signal to ECU, which decides if glow plugs are needed.

Alternatively - fuel leak, check fuel pipes and connections in engine bay, possibly faulty priming bulb
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #10
Member - SDI_TIM

Car jerky at light throttle/steady speed, no problem when accelerator pushed down a bit more = slightly sticky EGR valve. Clean valve, try an induction system cleaner e.g. 10K boost, or disconnect electronic control plug to disable EGR.
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #11
Member - Ursus 2

Watch the air con pipe near the air box filter ,posible wear of this pipe by the rub against this box
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #12
Member - Rovernaut

On the Intercooled Engine. The Engine Speed Governor Sensor and the Fuel Temperature Sensor are integral to the Fuel Injection Pump. If Diagnostics flag up either of these and you have limited performance. It's bad news I'm afraid. You will need a replacement pump. BUT YOU MUST set up the pump, as in the Haynes Manual, BEFORE you remove it.
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #13
Member - Mad

Came across this yesterday after a ic blew again. If you're having problems getting the car to rev at all from a cold start, there is a boost problem or egr problem, dont ask me whyy but it happens, the car wont rev for maybe 30 secs or so.
 

·
Registered
Joined
·
10,841 Posts
Discussion Starter #14
Hi guys, if anyone else has any great tips for this list, drop me a PM and ill add it up for you all :broon: :D
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top