MG-Rover.org Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi I have an issue with a non starter K Series 216 Coupe 1998MY I bought as a project,. hoping to save it from scrap, . .

Think its electrical or fuel. It will try to start but dies. so thought lack of fuel, I can hear fuel pump. 1/2 tank of fuel later and the starter turns over but will not fire. Have started once but ran rough. Had a look around engine bay for anything obvious and found a lose connector pictured unplugged under the inlet manifold . It is a branch from the main wiring loom just above gearbox. reach is probably 20 cm from branch so dont know if this is for an option not fitted or if its meant to be plugged in and this is part of my starting issue. Had a good look at all sorts of photos, haynes manual and for any possible place this should plug in and cannot locate. Any ideas what this plug is for?
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Hi I have an issue with a non starter K Series 216 Coupe 1998MY I bought as a project,. hoping to save it from scrap, . .

Think its electrical or fuel. It will try to start but dies. so thought lack of fuel, I can hear fuel pump. 1/2 tank of fuel later and the starter turns over but will not fire. Have started once but ran rough. Had a look around engine bay for anything obvious and found a lose connector pictured unplugged under the inlet manifold . It is a branch from the main wiring loom just above gearbox. reach is probably 20 cm from branch so dont know if this is for an option not fitted or if its meant to be plugged in and this is part of my starting issue. Had a good look at all sorts of photos, haynes manual and for any possible place this should plug in and cannot locate. Any ideas what this plug is for?
Found the socket at the back of the engine /gearbox just above the exhaust . plugged it in and she fired up straight away. :)
 
1 - 2 of 2 Posts
Top