MG-Rover.org Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello, I'm the owner of a Rover 75 cdt and the radio is not turning on
The radio is the one with a small screen on the left side that only displays the radio station. ( I will put a photo below)
Recently the radio has been acting up by turning on and off several times due to a flood caused by the plenum clogging. Now the radio has stopped working completely and it doesn't respond at all.
Is there any fuse I should replace our any connections I should clean to make it work ?
Thanks for the help
135483
 

·
Registered
rover_600
Joined
·
114 Posts
The good news is your head unit is indeed the Radio some are just a head unit with the Radio in the boot. Your radio has two din plugs a Rover multi plug and an Ariel connector at the back of it.
Remove the head unit 4 screws 2 holding the eyebrow on pop off plastic plate on the bottom of eyebrow gives access to them. Then slide out the eyebrow and you will see the two screws holding the radio in.
Using a multi meter check the orange and red wires going into the lesser populated din connector the red wire should come live when you turn on the ignition the orange one should be live all the time. If they are not live please check the fuse box above the passengers feet. I can’t remember off hand which is the offending fuse but there is usually a plastic sticker that tells you what fuse does what.
Hope this helps
Alan


Sent from my iPad using Tapatalk
 
1 - 2 of 2 Posts
Top