MG-Rover.org Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi, i've read a couple of threads on this issue, and i'm sure i have a dodgy relay, but will the dry joint issue affect cold starting as well as when its warm?
Does the 623 share the same relays and configuration as the 620?
Mine is a 1994, so will it have an alarm AND immobiliser? ?
Its failed to start twice now, once when warm and once when cold. Once it starts its fine, but i'm losing my faith in it........
Cheers
Stu
 

·
Registered
Joined
·
719 Posts
I cannot comment of the question of 620 / 623 variations, but dry joints are often totally unpredictable and just defy any logic.

With the 620, I sometimes that I can find useful info by looking on the net for the equivalent Honda Accord; wonder if there was a corresponding 2.3 Accord?

B
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Ok, thanks guys.
I dont suppose that there is an upgraded/retro-fit unit available?
Other than ebay, can you guys suggest anywhere else i may get one, or am i better of looking for a unicorn!
 

·
Rover Lifestyle
Rover 200 Rover 600
Joined
·
12,544 Posts
Usual problem with main relay is dry joints. Only that needs to be done is to use soldering iron and heat to repair dry joints. I would start with that and if no success go further.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
thanks guys, got the relay out and there was a couple of dodgy looking joints.
re-soldered them -not my area of expertise!
fingers crossed......
 
1 - 6 of 6 Posts
Top