MG-Rover.org Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, I've been trying to get my Rover 820i 4-cilinder turbo (engine 20T4G) going for a while now and i really hope someone can enlighten me.
So time ago the car started burning coolant so I replaced the head gasket, I've had some trouble setting the timing afterwards because the camshaft sprockets' exhaust/inlet arrows don't really seem to line up too well. The car starts but is shaky at idle and as soon as it reaches operating temperature it struggles and eventually stalls. To be sure I replaced spark plugs, fuel filter, thermostat and was thinking about replacing the temperature sensor beacuse of the stalling at operating temperature. Thing is, I tested the compression and the first cylinder has very high compression while the others have very poor compression (as can be seen in the photo, on the left is dry compression while on the right is the compression after adding some oil to the pistons).
It may well be bacuse of a wrong timing so I would appreciate a lot if someone could tell me if the marks on the sprockets are supposed to be well aligned or if they sort of deviate form the horizontal connecting all four marks (the sprockets are identical, and as far as I know the exhaust camshaft sprocket should face the other sprocket with the exhaust mark and same for the intake camshaft sprocket).
Or it may be because of the piston rings although the car was runnning way too well before the head gasket failure to be so. Or perhaps it has something to do with the valves but the tappets can be seen moving and when the head was removed there were no signs of excessive carbon buildup or any other issue. Any help is much appreciated, thanks a lot!
 

Attachments

·
Registered
Joined
·
31 Posts
Definatly something up with the compression i reckon, have you got the manufacturers stated specifications? What milage has the engine got on it? any previous damage, (overheating etc)?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Hello, thanks for your reply
I was hoping someone here could telle me the manufacturers specifications, although I'm sure the ones on my car are terribly low. The engine only has 80k km on it, it did overheat, which is when I decided to do the head gasket for the first time. I am starting to think that i might have bent the valves since we grinded the head without adjusting the valve deepness (I hope you understand what I mean, my mechanical jargon isn't very good). I was also considering changing the engine with an used one but in Italy there aren't many such cars let alone spare engines, I can find quite a few 20T4H engines while mine is a 20T4G, could somebody tell me what these engine codes mean? Like i guess the 20 mean 2.0 and the T is for T-series, what about the rest? I also found quite a few 20T2N.
Thanks in advance
 
1 - 4 of 4 Posts
Top