MG-Rover.org Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all,

I am after some info on the ABS system in the rover streetwise (or ZR) as it throws a light up while driving. I have bought into T16 turbo conversion project, but I assume the reluctor rings are different as its running different shafts from a K4BS 220 coupe gearbox. Before I buy new streetwise rings how many are there and where or what ecu is controlling it. Its not something i have seen commonly discussed on forums in my case, but im interested to see if its been done and working on other builds. I assume the abs pump has its own internal ecu and separate from MEMS etc. Ive asked other forums before but the usual answer is to pull the ABS fuse and just put zr 160 and zs 180 calipers on it. Any advice appreciated.
Thanks......
 

·
Registered
Joined
·
2 Posts
Good question, im about to/am in the process of doing something similar. Im fitting a wasted spark engine from an 800 vitesse in to a mk3 bubble 200. On the bubble the ABS appears totally separate. The car body loom plugs into the valve block, engine loom is separate. I bought some shafts which i think must be off a diesel. They have the reluctor rings that have more teeth on them than the 220 coupe and other r8 cars. I hoe they will just work, but we shall see.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Good question, im about to/am in the process of doing something similar. Im fitting a wasted spark engine from an 800 vitesse in to a mk3 bubble 200. On the bubble the ABS appears totally separate. The car body loom plugs into the valve block, engine loom is separate. I bought some shafts which i think must be off a diesel. They have the reluctor rings that have more teeth on them than the 220 coupe and other r8 cars. I hoe they will just work, but we shall see.
HI Jim

Would like to see how that plays out, still having issues on my end with this. I have not fitted the reluctor ring yet but will aim to do so sometime in the week. I have tested both sensors and both give the same resistance readings, therefore most probable its going to be the ring or ABS pump. Guess ill find out soon enough once the ring is fitted.

Cheers.
 
1 - 3 of 3 Posts
Top