MG-Rover.org Forums banner

321 - 340 of 347 Posts

·
Registered
Joined
·
836 Posts
Can anyone shed some light why I have leaks please? 3&4 is leaking quite badly from what looks like the base of injector.

I have removed them, cleaned bore and step again, used new washers and greased both sides.

Done four but this one seems to be a real pain. Thanks

A thin smear of hylomar on the threads of the cap can help if the leak is coming from here. I thin I had to do that on the injectors I fitted to someones car on here.
Yes my new injectors (rebuilt) were leaking after much faffing about, no's 1,2,4 to be exact. I removed them and put the old ones back in which cured the problem, I am awaiting the firm to rectify this but not happy at all, I'm requesting a flow test and data sheet from them also.

At this stage I won't be naming the firm depending on the outcome, but much trouble has been caused.

Issue I now have is since replacing the old ones the car has developed a flat spot on hard power on, almost fuel starvation symptoms.

I replaced the fuel filter which has had no effect, hoses check out fine, I can only imagine the injectors went back in a different order to which I removed them???

Prior to this I drove the car down from Inverness to the Midlands and it was running totally superb. Any ideas before I get the new injectors back???
 

·
Registered
Joined
·
5,348 Posts
some people have had issues with the small filter on the fuel inlet to the pump (a bit of gauze)

Undo, clean, and refit. Hopefully that'll sort it?
 

·
Registered
Joined
·
836 Posts
some people have had issues with the small filter on the fuel inlet to the pump (a bit of gauze)

Undo, clean, and refit. Hopefully that'll sort it?

Nice thought know the one, maybe I disturbed it thanks
Removed and back flushed, still no results. Been over hoses once again, all checks out. Also tried MAF disconnection for what it's worth.

Car is pulling up to 3900 then holding back. All I did was remove injectors and replace, car was totally superb up till then.

Have to wait for new ones I think, pretty sure that'l solve it?
 

·
Registered
Joined
·
836 Posts
Sure did, as said its not compression blow back. My only thought now is I put them back in a different order which doesn't suit as much as testing proved one is 190 bar.

Just wondering if there's anything else I've missed, convinced its injector issue
 

·
Registered
Joined
·
836 Posts
Thanks, I'm also wondering if it's wiring damage to no 1 injector, cleaned plug & socket up today. Would that give fuel starvation symptoms though?

As I said, all I did is remove and replace the injectors so I must have disturbed something...
 

·
Registered
Joined
·
836 Posts
Damage to plug or wiring to injector 1 lift sensor?
Yep that cracked it!

Lucky I have three sets of SDi's in stock so replaced no 1.

Must have damaged the lead, they have been in and out the car three times now though due to waiting on the new ones.

Many thanks!
 

·
Registered
rover_25
Joined
·
301 Posts
I´ve been hearing two versions..

That installing the SDi Injectors, the boost automatically rises a little

That installing the SDi Injectors, the boost doesn´t changes nothing

What of the two are correct?

One more question. If the correct case is the second, which gains can be expected from installing the injectors and doesn´t change the boost?
 

·
Registered
rover_25
Joined
·
301 Posts
And about fitting the injectors and adjusting the boost to standard values?

Will it give any noticeable power increment?
 

·
Registered
rover_25
Joined
·
137 Posts
And about fitting the injectors and adjusting the boost to standard values?

Will it give any noticeable power increment?
It would but it would be very smoky due to over fuelling but as you said above the boost would increase slightly anyway so you would see a noticeable change.
 

·
Registered
Joined
·
349 Posts

·
Registered
Joined
·
929 Posts
It would but it would be very smoky due to over fuelling but as you said above the boost would increase slightly anyway so you would see a noticeable change.
It made a big difference to my mk2 zs. Mondeo st TD couldn't keep up afterwards.

I also noticed increasing the boost to 19psi reduced the smoke a bit too...
 
321 - 340 of 347 Posts
Top