MG-Rover.org Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi all,

So I’ve owned my TF for around 6 months now, and I’ve been constantly battling with the drivers door lock.

After replacing the whole barrel and door handle itself for a new unit, it seems to only unlock and lock on the key a handful of times before not working again. The key fob seems to work fine, however.

Well, today I stripped the door card off again to take a look. Upon inspection, it looks as if the little o-ring/clip that connects the lock unit to the connecting rod for the door had come loose. Popping it back into place, and resting the lock, it seems to work fine.

I did notice this little o-ring though, became loose after only a few turns - and pretty soon I couldn’t get the purchase needed to unlock the car. Pretty sure this is the cause of the issues I’ve described.

Has anyone else here experienced this issue? Is there anything I can do to ensure the little o-ring is seated correctly (visually, it looks fine but one key turn and you’ll see it works loose) or prevent it coming loose? Or is this a little seal I should in fact replace m?

Any help/ guidance appreciated.
Thanks!
 

·
Premium Member
Joined
·
888 Posts
Hi. This happens to me. The spring clip can be mounted upside down. I gave it an extra bend to make sure it stayed in place. Also sometimes the key can get stuck in the lock and not turn the barrel. I run a soft pencil along the key every now and then.
 
1 - 2 of 2 Posts
Top